open ros projects with clion

asked 2015-07-03 23:42:00 -0600

Juni gravatar image

updated 2015-07-03 23:47:55 -0600

Hello.

I'm trying to use CLion for new IDE, previously I've used Eclipse.

But now I have one problem.

I want to open this project with CLion.

Top directory is pioneer_gazebo_ros and it contains 3 different packages (pioneer_description, pioneer_gazebo, pioneer_ros respectively).

What I did was as follows.

[File]->[Open]->Select [pioneer_gazebo_ros] folder.

What I wanted to do was opening 3 packages at once.

But CLion kept showing this message on CMake->Problems toolbar.

Error:CMakeLists.txt not found in /home/ub1404/catkin_ws/src/pioneer_gazebo_ros

And I couldn't navigate the codes and use intellisense functionality at all.

Anybody solved this problem?

Thanks.


Here is the screenshot.

edit retag flag offensive close merge delete

Comments

gvdhoorn gravatar imagegvdhoorn ( 2015-07-04 02:24:24 -0600 )edit
1

Yes, I read it. Now I solved it. I did it by Import Project rather than Open. And I imported only src directory and as of now it seems fine. If whole catkin_ws(including build, devel folder) is imported, it seems that intellisense does not work properly.

Juni gravatar imageJuni ( 2015-07-04 03:21:05 -0600 )edit