Ask Your Question
0

Can't run gmapping [closed]

asked 2015-06-30 10:37:48 -0500

rosfuncoolstuff gravatar image

updated 2015-06-30 10:44:11 -0500

I am running gmapping on ROS Indigo. I installed gmapping by

sudo apt-get install ros-indigo-gmapping
rosmake gmapping

When I run it, I followed this tutorial: http://wiki.ros.org/slam_gmapping/Tut... However, when I run

rosrun gmapping slam_gmapping scan:=base_scan

I got this error:

slam_gmapping: tpp.c:62: __pthread_tpp_change_priority: Assertion `new_prio == -1 || (new_prio >= __sched_fifo_min_prio && new_prio <= __sched_fifo_max_prio)' failed.

Aborted (core dumped)

How can I solve this? Any help is much appreciated!

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by allenh1
close date 2015-07-07 19:41:45.094656

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-07-06 14:09:45 -0500

rosfuncoolstuff gravatar image

Just updated pthread and boost, problem solved...

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2015-06-30 10:37:48 -0500

Seen: 271 times

Last updated: Jul 06 '15