Ask Your Question
0

PX4 RC override doesn't work

asked 2015-06-29 04:46:01 -0500

Flavio90 gravatar image

Hi guys, i'm using a pixhawk with ardurover inside. I'm trying to use a ROS node to override the RC channels and drive my rover, through the telemetry. Earlier I managed this problem and i was able to drive the motors of the rover from a ROS node, but now it is not working anymore. I see the right values both on the rc_override and rc_in topics, but not on the rc_out topic, so the rover doesn't move. Do I have to check the GCS_SYSTEM_ID or something similar? Actually, it is already set to 255 (1). Is there a specific "flight mode" that allows the override? I don't know anymore what to do.

Thanks a lot for your help, Flavio

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-06-30 04:36:34 -0500

vooon gravatar image
edit flag offensive delete link more

Comments

Actually, that parameter is already set to 1, but che override doesn't work. Do you have other suggestions?

Flavio90 gravatar imageFlavio90 ( 2015-06-30 05:38:33 -0500 )edit

And used default launch?

vooon gravatar imagevooon ( 2015-07-12 03:27:04 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-06-29 04:46:01 -0500

Seen: 829 times

Last updated: Jun 30 '15