Ask Your Question
1

Eclipse unresolved includes

asked 2015-06-11 03:38:33 -0500

hannjaminbutton gravatar image

updated 2015-06-11 03:38:59 -0500

Hey,

I'm trying to use Eclispe (Indigo) with ROS (Hydro). I can import my packages but I still have inresolved includes. I followed the Turorial but I'm not able to do this step:

In Eclipse, right click the project, click properties -> C/C++ general -> Preprocessor Include Paths, Macros etc. Click the tab "Providers" and check the box next to "CDT GCC Built-in Compiler Settings [ Shared ]".

When I click on porperties -> c/c++ general there is no Preprocessor Include Paths, Macros etc.

Is there any way to solve this problem in another way?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-06-11 11:39:46 -0500

raghav.rao32 gravatar image

Did you click on the small black triangle next to C/C++ General? If you clicked on just C/C++ General it should just say "Enable Project Specific Settings" which is not the option you want.

On Eclipse Luna, which is what I'm using, under C/C++ General it says: >Code analysis, Documentation, File Types, Formatter, Indexer, Language Mapping, Preprocessor Include Paths and Profiling Catagories.

If any of those are missing, you might want to consider using a more recent version of eclipse.

If adding CDT GCC Built-in Compiler Settings [ Shared ] doesn't fix your problem, make sure to check Project -> Properties -> C/C++ Include Paths and Symbols, and see if /usr/include/c++/4.x and /usr/include/c++/4.x/backward are in there. 4.x for me was 4.8. Check yours by using your file manager and going to /usr/include.

Remember to go to Project ->C/C++ Index after finishing.

It should be fixed by then, assuming you installed eclipse and ran it from terminal with bash -i -c "eclipse

edit flag offensive delete link more

Comments

Yes, I clicked on the triangle. For my version it only says Code Style, Documentation, File Types, Indexer and Language Mapping. I also included these paths but its still not working. But thanks for your answer, I will get a more recent version of eclipse!

hannjaminbutton gravatar image hannjaminbutton  ( 2015-06-12 00:12:04 -0500 )edit

http://answers.ros.org/question/52013... The top rated answer will help you. I battled with the same problem for a week. sourcing seems to be the answer

Reiner gravatar image Reiner  ( 2015-06-16 03:26:49 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2015-06-11 03:38:33 -0500

Seen: 995 times

Last updated: Jun 11 '15