ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A answers.ros.org
Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Did you click on the small black triangle next to C/C++ General? If you clicked on just C/C++ General it should just say "Enable Project Specific Settings" which is not the option you want.

On Eclipse Luna, which is what I'm using, under C/C++ General it says: >Code analysis, Documentation, File Types, Formatter, Indexer, Language Mapping, Preprocessor Include Paths and Profiling Catagories.

If any of those are missing, you might want to consider using a more recent version of eclipse.

If adding CDT GCC Built-in Compiler Settings [ Shared ] doesn't fix your problem, make sure to check Project -> Properties -> C/C++ Include Paths and Symbols, and see if /usr/include/c++/4.x and /usr/include/c++/4.x/backward are in there. 4.x for me was 4.8. Check yours by using your file manager and going to /usr/include.

Remember to go to Project ->C/C++ Index after finishing.

It should be fixed by then, assuming you installed eclipse and ran it from terminal with bash -i -c "eclipse