Ask Your Question
0

rviz and openGL

asked 2015-06-05 19:21:10 -0500

Zozo gravatar image

updated 2015-06-07 02:00:14 -0500

gvdhoorn gravatar image

I am trying to run rviz but I face this error:

[ INFO] [1433549504.115313245]: rviz version 1.11.7
[ INFO] [1433549504.115355680]: compiled against OGRE version 1.8.1 (Byatis)
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
[ INFO] [1433549504.568675398]: Stereo is NOT SUPPORTED
[ INFO] [1433549504.568842811]: OpenGl version: 1.4 (GLSL 0).
terminate called after throwing an instance of 'std::runtime_error'
  what():  Your graphics driver does not support OpenGL 2.1. Please enable software rendering before running RViz (e.g. type 'export LIBGL_ALWAYS_SOFTWARE=1').
Aborted (core dumped)

I run this: export LIBGL_ALWAYS_SOFTWARE=1 but I still have the same problem.

I installed ork(http://wg-perception.github.io/object_recognition_core/install.html#install) on ROS some days ago and it asked me to install MESA. I installed this version of MESA.10.5.4 from this link: http://www.mesa3d.org/

I want to know if the problem is my graphic driver? Is anyone know how I can resolve it?

This is my openGL info:

OPENGL info:
Renderer: GeForce GTX/745
Version: 1.4 (2.1.2 NVIDIA 331.113

the graphic driver:

 description: VGA compatible controller
       product: GM107 [GeForce GTX 745]
       vendor: NVIDIA Corporation

Edit:

To install ORK, I run catkin_make, and it failed in the middle and said it couldn't find mesa libraries. That's why I installed mesa. It needed this library: libosmesa

http://wg-perception.github.io/object...

For mesa, I run this:

./configure --build=x86_64-pc-linux-gnu --host=i686-pc-linux-gnu --enable-osmesa --with-osmesa-bits=32

and then make it.

I use UBUNTU 14.04 LTS(Trusty) ROS indigo

edit retag flag offensive close merge delete

Comments

You say you "installed this version of MESA 10.5.4 from this link". What did you do exactly? I doubt orc requires the newest Mesa libs, installing them using your platform's package manager would probably have been enough. If you make && sudo make install, then some things are probably broken now.

gvdhoorn gravatar image gvdhoorn  ( 2015-06-06 08:02:17 -0500 )edit

Also: which OS, version of OS, which ROS release, etc.

gvdhoorn gravatar image gvdhoorn  ( 2015-06-06 08:02:54 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
0

answered 2015-06-07 02:23:50 -0500

gvdhoorn gravatar image

For mesa, I run this:

./configure --build=x86_64-pc-linux-gnu --host=i686-pc-linux-gnu --enable-osmesa --with-osmesa-bits=32

and then make it.

This is probably what is causing your issues: if you also did a sudo make install, that has most likely overwritten some files and / or symlinks involved in the 3D acceleration pipeline of your system.

I use UBUNTU 14.04 LTS [..]

It is generally recommended to use the OS package manager to install software on Ubuntu (and any other Linux distro that has a pkg manager, really). For libosmesa, perhaps the following would've been enough:

sudo apt-get install libosmesa6-dev

You could try and see whether installing those packages restores your system to a working state (remember to rebuild ORK). If not, you might also need to reinstall your graphics card driver.

A properly installed (and working) OpenGL system should show you a Version 3.x or Version 4.x in your OpenGL Info along with some other vendor specific information.

To install ORK, I run catkin_make, and it failed in the middle and said it couldn't find mesa libraries. [..]

A rosdep check --from-paths /paths/to/your/ork_ws -i should've tried to install libosmesa6-dev, as it is listed as a build_depend in ork_rendered's package manifest. I don't see rosdep mentioned in the installation document you linked, so perhaps it's an idea to run it.

edit flag offensive delete link more
0

answered 2021-03-03 19:05:32 -0500

I had the same issue, this link helped me fix the issue:

https://github.com/ros-visualization/...

edit flag offensive delete link more
0

answered 2015-06-08 16:22:16 -0500

Zozo gravatar image

updated 2015-06-08 17:20:48 -0500

Thanks for the respond.

I tried sudo apt-get install libosmesa6-dev before, but it had dependency issue. This is the error I get after running this command:

    Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libosmesa6-dev : Depends: libosmesa6 (= 10.1.3-0ubuntu0.4) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

So, I had to install it from source. I couldn't make it work today, I reinstall my graphic driver 3 times today but still the OpenGL version was 1.4.

I decided to work with the on-board graphic card then. So I reinstall the Ubuntu. This is my new graphic card info:

VGA compatible controller: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller (rev 06)

Good news is OpenGL version is 3.0 now. OpenGL version string: 3.0 Mesa 10.3.2

But. I am again in the point which ORK couldn't find osmesa. And I can't install it using OS package manager because of the same error I was writing above.

This is the error while installing ORK:

 ros_ws/src/ork_renderer/src/renderer3d_impl_osmesa.h:39:23: fatal error: GL/osmesa.h: No such file or directory
     #include <GL/osmesa.h>

You know what I should do at this point?

Thanks again for the respond.

edit flag offensive delete link more

Comments

Please do not use answers to post comments or updates to your questions.

gvdhoorn gravatar image gvdhoorn  ( 2015-06-08 16:23:51 -0500 )edit

Could you update your question with what "it has dependency issue" actually means? Without info, we can only guess.

gvdhoorn gravatar image gvdhoorn  ( 2015-06-08 16:24:36 -0500 )edit

Thanks. I updated my question.

Zozo gravatar image Zozo  ( 2015-06-08 17:19:09 -0500 )edit

I installed ORK on my laptop before without getting any error. Do you know why I have mesa problem here? It is because of the graphic card or something else might have made this issue? My laptop OS was Ubuntu 14.04 LTS and also I had ROS indigo.

Zozo gravatar image Zozo  ( 2015-06-08 17:44:29 -0500 )edit

As you mentioned, I run this rosdep check --from-paths src --ignore-src --rosdistro indigo and this is the message:

System dependencies have not been satisified:
apt libosmesa6-dev
apt meshlab
Zozo gravatar image Zozo  ( 2015-06-08 18:36:14 -0500 )edit

It's very hard to solve these kind of problems remotely. I can only advise you to check carefully you have installed the proper pkgs for your graphic card, then try to install libosmesa6-dev. If it doesn't want to, try figuring out why not.

gvdhoorn gravatar image gvdhoorn  ( 2015-06-17 05:41:56 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-06-05 19:21:10 -0500

Seen: 6,860 times

Last updated: Jun 08 '15