Ask Your Question
0

nao_teleop not working [closed]

asked 2015-05-13 09:57:21 -0600

Tirgo gravatar image

Hello,

i am running ros indigo and naoqi 2.1.3.3. My problem is i am not able to control the robot via joystick. I can stand up and sit down, but i am not able to move. Some more informations which may help:

If i start the Nao via:

roslaunch nao_bringup nao_full.launch

i am getting the warning:

[WARN] [WallTime: 1431528769.622096] stop_walk_srv not available, pose_manager will not stop the walker before executing a trajectory. This is normal if there is no nao_walker running.

Also the topic /cmd_vel is not available for the Nao.

Before i run hydro with an older naoqi version and everything worked fine. Does some have a suggestion? I am pretty lost.

Thanks

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Tirgo
close date 2015-12-09 02:34:11.005179

Comments

I found the solution: The nao_walker.py script is currently taking place in the nao_apps package. Unfortunately the script is not marked as executable. I don't know if it is a bug. I tested it on an other machine (downloaded it again) and it was also not executable per default. Same with nao_speech!

Tirgo gravatar imageTirgo ( 2015-05-18 02:46:39 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-12-09 02:33:55 -0600

Tirgo gravatar image

Everything works fine now. It was fixed!

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2015-05-13 09:57:21 -0600

Seen: 157 times

Last updated: Dec 09 '15