Ask Your Question
0

Trouble running nao_driver package

asked 2014-03-24 07:24:02 -0500

florabranchi gravatar image

updated 2016-10-24 09:00:15 -0500

ngrennan gravatar image

Hello,

I have been trying for a few days to run nao_driver package, with no sucess. I looked around for answers, but none of the solutions could help me. Aparently, Naoqi is set up correctly, since I can import it with "import naoqi" in python. However, when I try to run something like "LD_LIBRARY_PATH=~/nao/tools/pynaoqi-python-2.7-naoqi-1.14-linux64:$LD_LIBRARY_PATH NAO_IP=127.0.0.1 roslaunch nao_driver nao_driver_sim.launch" , I get the following errors:

@florabranchi-Dell-System-XPS-15Z:~/nao/tools/pynaoqi-python-2.7-naoqi-1.14-linux64$ LD_LIBRARY_PATH=~/nao/tools/pynaoqi-python-2.7-naoqi-1.14-linux64:$LD_LIBRARY_PATH NAO_IP=127.0.0.1 roslaunch nao_driver nao_driver_sim.launch ... logging to /home/florabranchi/.ros/log/c37b6108-b373-11e3-beca-848f69cd2cc7/roslaunch-florabranchi-Dell-System-XPS-15Z-7419.log Checking log directory for disk usage. This may take awhile. Press Ctrl-C to interrupt Done checking log file disk usage. Usage is <1GB.

started roslaunch server

SUMMARY

PARAMETERS * /nao_sensors/use_joint_sensors * /rosdistro * /rosversion

NODES / nao_behaviors (nao_driver/nao_behaviors.py) nao_controller (nao_driver/nao_controller.py) nao_leds (nao_driver/nao_leds.py) nao_sensors (nao_driver/nao_sensors.py) nao_speech (nao_driver/nao_speech.py) nao_tactile (nao_driver/nao_tactile.py) nao_walker (nao_driver/nao_walker.py)

core service [/rosout] found process[nao_sensors-1]: started with pid [7437] process[nao_walker-2]: started with pid [7438] No handlers could be found for logger "rosout" process[nao_controller-3]: started with pid [7441] No handlers could be found for logger "rosout" process[nao_behaviors-4]: started with pid [7444] ================================================================================REQUIRED process [nao_sensors-1] has died! process has died [pid 7437, exit code 1, cmd /home/florabranchi/catkin_ws/src/nao_robot/nao_driver/nodes/nao_sensors.py --pip=127.0.0.1 --pport=9559 __name:=nao_sensors __log:=/home/florabranchi/.ros/log/c37b6108-b373-11e3-beca-848f69cd2cc7/nao_sensors-1.log]. log file: /home/florabranchi/.ros/log/c37b6108-b373-11e3-beca-848f69cd2cc7/nao_sensors-1*.log Initiating shutdown! ================================================================================ No handlers could be found for logger "rosout" cannot add process [nao_leds-5] after process monitor has been shut down No handlers could be found for logger "rosout" [nao_behaviors-4] killing on exit [nao_controller-3] killing on exit [nao_walker-2] killing on exit [nao_sensors-1] killing on exit

I have tried force_python:=true and it still doesn't work :( It seems that the process just dies, and doesn't tell me the error. Are those "No handlers could be found for logger "rosout" normal?

Does anyone have the same problem or can help me solving this?

Thanks

edit retag flag offensive close merge delete

Comments

1

Is there a reason why you add the pynaoqi module path to your LD_LIBRARY_PATH? I think the path should only be in your PYTHONPATH, not LD_LIBRARY_PATH.

AHornung gravatar image AHornung  ( 2014-03-25 03:40:18 -0500 )edit

To (possibly) get more output, you could also try to run only the nao_sensors node: "rosrun nao_driver nao_sensors.py"

AHornung gravatar image AHornung  ( 2014-03-25 03:43:27 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-05-23 21:29:49 -0500

Vincent Rabaud gravatar image

As mentioned by AHornung, your problem is that you need to do:

export PYTHONPATH=~/nao/tools/pynaoqi-python-2.7-naoqi-1.14-linux64:$PYTHONPATH

(and not LD_LIBRARY_PATH). The error you get (though totally unexplicit) is typical from not finding naoqi on your PYTHONPATH

edit flag offensive delete link more

Comments

And btw, the code just changed to give a normal error code. That should appear in the next release.

Vincent Rabaud gravatar image Vincent Rabaud  ( 2014-08-01 06:51:25 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-03-24 07:24:02 -0500

Seen: 1,427 times

Last updated: May 23 '14