Ask Your Question
1

SBPL_Exception* error while using SBPLLatticePlanner in ros indigo

asked 2015-05-13 09:24:02 -0500

Naman gravatar image

updated 2015-05-22 14:53:24 -0500

Hi all,

I am planning to use SBPL Lattice Planner as a Global Planner. I have sbpl and sbpl_lattice_planner set up in ROS Indigo. Then when I run roslaunch sbpl_lattice_planner move_base_sbpl_fake_localization_2.5cm.launch, I get the following runtime error:

image description

Also, I have followed this to make all the necessary changes. Does anyone has any idea about what is causing this error and how can it be solved?

Thanks in advance.
Naman Kumar

edit retag flag offensive close merge delete

Comments

1

Have you setted .mprim file for your move_base node correctly?

Orhan gravatar imageOrhan ( 2016-02-19 02:46:53 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-09-17 14:24:32 -0500

shaoshuai gravatar image

I have suffered this issue, too. If you ran it in ROS, the SBPL should print the errors in detail. You can check out the log file to see what the exact reason there is an "SBPL_Exception*". Otherwise, you might need to change the way "SBPL" publishes the errors, for instance, open /sbpl/src/include/sbpl/config.h and change #define DEBUG 0 in line 53 to #define DEBUG 1.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-05-13 09:24:02 -0500

Seen: 192 times

Last updated: May 22 '15