Ask Your Question
0

global path planner pass through high cost area on local cost map

asked 2014-09-02 12:10:32 -0500

dreamcase gravatar image

hi, all,

the global path planner on my robot NavfnROS always produces plans that pass through dark area on local cost map. and whenever it does so, the robot refuses to move. I guess it's because there's a risk for collision. my parameter settings are quite simple

NavfnROS:
  allow_unknown: false

how do I prevent the planner giving plan that transverse dark area on the local cost map

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-09-02 20:16:05 -0500

You have to make sure that the "dark area" on the local cost map also appears on the global cost map. If I am not mistaken, the global path planner does not take into account the local cost map.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2014-09-02 12:10:32 -0500

Seen: 193 times

Last updated: Sep 02 '14