Ask Your Question
0

ROS/Hydro installation error: library '-framework Cocoa' is neither a target nor built/installed properly

asked 2015-05-07 11:03:40 -0600

Whitesail gravatar image

updated 2015-05-07 13:06:16 -0600

Hi,

I tried to install ROS/Hydro in OS X10.9 with homebrew following with :http://wiki.ros.org/hydro/Installation/OSX/Homebrew/Source

When I run $ rosdep install --from-paths src --ignore-src --rosdistro hydro -y, I got

 CMake Error at /Users/Baifan/ros_catkin_ws/install_isolated/share/pcl_ros/cmake/pcl_rosConfig.cmake:141 (message):
  Project 'depth_image_proc' tried to find library '-framework Cocoa'.  The
  library is neither a target nor built/installed properly.  Did you compile
  project 'pcl_ros'? Did you find_package() it before the subdirectory
  containing its code is included?
Call Stack (most recent call first):
  /Users/Baifan/ros_catkin_ws/install_isolated/share/catkin/cmake/catkinConfig.cmake:75 (find_package)

CMakeLists.txt:8 (find_package)
-- Configuring incomplete, errors occurred!
See also "/Users/Baifan/ros_catkin_ws/build_isolated/depth_image_proc/CMakeFiles/CMakeOutput.log".
<== Failed to process package 'depth_image_proc': 
  Command '/Users/Baifan/ros_catkin_ws/install_isolated/env.sh cmake /Users/Baifan/ros_catkin_ws/src/image_pipeline/depth_image_proc -DCATKIN_DEVEL_PREFIX=/Users/Baifan/ros_catkin_ws/devel_isolated/depth_image_proc -DCMAKE_INSTALL_PREFIX=/Users/Baifan/ros_catkin_ws/install_isolated -DCMAKE_BUILD_TYPE=Release' returned non-zero exit status 1

1) I installed pcl-ros. But I got error

 CMake Error at /usr/local/share/pcl-1.8/PCLConfig.cmake:47 (message):
  simulation is required but glew was not found
, then in CMakeCache.txt of pcl_ros, I replaced the line GLEW_INCLUDE_DIR:PATH=GLEW_INCLUDE_DIR-NOTFOUND to GLEW_INCLUDE_DIR:PATH=/usr/local/Cellar/glew/1.11.0/include/GL and replaced the line GLEW_GLEW_LIBRARY:STRING=-framework GLEW to GLEW_GLEW_LIBRARY:FILEPATH=/usr/local/Cellar/glew/1.11.0/lib/libGLEW.dylib. It seems pcl-ros installed successfully.

2)I found there is find_package(PCL) in CMakeLists.txt of depth_image_proc.

So I don't know how to fix '-framework Cocoa' library problem. Can you help me?

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2015-05-07 15:10:16 -0600

Whitesail gravatar image

I fixed the problem by replacing the line GLEW_COCOA_LIBRARY:STRING=-framework Cocoa to GLEW_COCOA_LIBRARY:FILEPATH= /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.9.sdk/System/Library/Frameworks/Cocoa.framework in CMakeCache.txt of pcl_ros.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-05-07 11:03:40 -0600

Seen: 480 times

Last updated: May 07 '15