ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Failed path planning Moveit+RIVZ

asked 2015-04-30 00:13:40 -0500

Arowana gravatar image

updated 2015-04-30 04:39:54 -0500

I am trying to learn of to do path planning with RVIZ+MoveIt for a UR5 arm. For now I'm trying to simulate only. I use Gazebo4, RVIZ+MoveIt and universal_robot packages that I built from source for ROS Indigo.

I run these 3 command in 3 different terminal, as written in the universal_robot's README :

roslaunch ur_gazebo ur5.launch

roslaunch ur5_moveit_config ur5_moveit_planning_execution.launch sim:=true

roslaunch ur5_moveit_config moveit_rviz.launch config:=true

I have several issues and I don't really now what is the origin. I tried to do path planning from RVIZ, on a simple path from home to up position and from up to home. Sometimes I have "Failed" message in the GUI, sometimes it works. But most of the time it didn't. I struggle to find proper documentation to use the motion planning panel

I have the following error messages

Terminal #2 :

[ WARN] [1430368642.447147735, 185.001000000]: Controller  failed with error code PATH_TOLERANCE_VIOLATED
[ WARN] [1430368642.447324161, 185.001000000]: Controller handle  reports status ABORTED

Terminal #3:

 [ WARN] [1430368548.820347974, 107.047000000]: Fail: ABORTED: Motion plan was found but it seems to be invalid (possibly due to postprocessing). Not executing.

If I use the Moveit command-line commander

rosrun moveit_commander

And try to "go goal" with goal from "rec c" then modifiy joint angles. Sometimes it works, but I still have this bug sometimes :

manipulator> go goal
[ INFO] [1430370662.457107039, 2110.983000000]: ABORTED: Solution found but controller failed during execution
Failed while moving to goal

I run it in VirtualBox and I can have 8 FPS in RVIZ.

EDIT : I notice than even if I ask for simple joint movement

  group.set_joint_value_target([1.5, 0, 1.5, 0, 0, 0])

I have the error

[ WARN] [1430368642.447147735, 185.001000000]: Controller  failed with error code PATH_TOLERANCE_VIOLATED
edit retag flag offensive close merge delete


Are you using the pkg from apt-get, or github? If you were the one who created the moveit_config package you're using, I would say you just have to create controller configs (see this.

130s gravatar image 130s  ( 2015-04-30 01:48:09 -0500 )edit

from apt-get for all of them except universal_robot packages, I build it from indigo branch of the git repo, The arm move most of the time, it means that the controller is configured. I have the errors messages but not always. Moreover I don't have any message related to wrong controller config.

Arowana gravatar image Arowana  ( 2015-04-30 02:09:14 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2015-05-07 04:58:02 -0500

Arowana gravatar image

I moved to a powerful PC. I installed Ubuntu 14.04 and all needed packages. The problem is gone. Seems that the controller was not able to compute fast enough, because before it was very slow in VM.

I am not sure of why this thing happened.

edit flag offensive delete link more


Is there no way to just slow down the execution of the planned trajectory so as to give the computer more time for the calculations? I ran into the same kind of issues and don't really have the opportunities to switch over to a more powerful computer...

budekatude gravatar image budekatude  ( 2017-07-12 04:24:55 -0500 )edit

Question Tools

1 follower


Asked: 2015-04-30 00:13:40 -0500

Seen: 4,856 times

Last updated: May 07 '15