Ask Your Question
0

Eclipse custom message unresolved inclusion

asked 2015-04-29 12:56:05 -0500

Mago Nick gravatar image

Hello everybody, I know that might be a common question, but all the solutions I have found did not work. I can import my project (around 35 packages) and all the inclusions work perfectly. However, when comes to the inclusion of messages it shows an error and says that the inclusion of the message header is unresolved even if the message is defined in the same package where it is used. Moreover, it builds the project without any problem. Of course I followed the steps in the wiki to set up Eclipse with ROS and catkin. Any clues on what it can be?

Thank you very much

Andrea

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2015-04-30 06:59:19 -0500

Mago Nick gravatar image

It was a compiling problem. There were some packages with errors and the messages were not generated. To verify it I looked in the devel/include folder of the workspace.

Thank you very much anyway Andrea

edit flag offensive delete link more
0

answered 2019-09-16 02:53:29 -0500

Berg gravatar image

It seems the /devel/include/ folder need to be added to the list of 'include Paths' of c/c++.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-04-29 12:56:05 -0500

Seen: 349 times

Last updated: Apr 30 '15