Ask Your Question
0

Rviz doesn't update rolling-window costmap origin

asked 2015-04-24 02:44:59 -0600

Rr gravatar image

updated 2015-04-26 02:49:16 -0600

If I disable and then enable costmap view in rviz, it updates. But rviz itself doesn't translate cosmap update, it draws it with old origin.

It even happens for husky_navigation example.

How could I configure rviz to view rolling-window cosmap with moving origin right?

Here are 2 screenshots - first with costmap view shifted and second with correct visualisation after disable and then enable costmap view in rviz:

shifted

correct

Here is video: video

I use ROS Indigo, Ubuntu 14.04. I tried at different computers, on VM and without, at just-installed ROS with same result.

Thanks

edit retag flag offensive close merge delete

Comments

What version of ROS, OS, and rviz are you using? Can you give a link to the husky_navigation example?

William gravatar imageWilliam ( 2015-04-24 15:27:32 -0600 )edit

Ubuntu 14.04, ROS Indigo. http://wiki.ros.org/husky_navigation/...

Rr gravatar imageRr ( 2015-04-26 02:17:03 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2015-04-26 03:41:10 -0600

Rr gravatar image

I think, I solved this problem for myself. The issue was that Rviz doesn't correctly use /move_base/global_costmap/costmap_updates (of map_msgs/OccupancyGridUpdate type), so setting parameter always_send_full_costmap: true to costmap does the job.

edit flag offensive delete link more
0

answered 2015-04-29 11:51:14 -0600

DLu gravatar image

This is a previously unrealized bug with using the OccupancyGridUpdate message. https://github.com/ros-planning/navig...

Thanks for the report.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-04-24 02:44:59 -0600

Seen: 387 times

Last updated: Apr 29 '15