Ask Your Question
10

'catkin build' gives 'command not found

asked 2015-04-20 08:08:23 -0500

Nap gravatar image

I have ROS Indigo Desktop Full installed from binaries on Ubuntu 14.04.2.

I've been reading about the catkin make system, and am lead to believe there are 3 variations:

  • catkin_make
  • catkin_make_isolated, and
  • catkin build

I'm familiar with the first two and have used them for my projects, but I would like to make use of catkin build but I get an error catkin: command not found. There is no catkin script or executable in the /opt/ros/indigo/ folder structure.

What could be going wrong? Is there something else I need to install?

Cheers,
Nap.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
12

answered 2015-04-20 08:27:26 -0500

The catkin build command is part of the catkin_tools package. On apt-get the package is called python-catkin-tools.

The documentation for the package can be found here: http://catkin-tools.readthedocs.org/e...

Since the package was officially released, I have completely stopped using catkin_make. It is a great package!

edit flag offensive delete link more

Comments

@jarvisschultz : Thanks!!

Nap gravatar image Nap  ( 2015-04-20 08:34:24 -0500 )edit
4

I issued this command in the terminal, and it worked:

sudo apt-get install python-catkin-tools

Thank you!

mwycliff gravatar image mwycliff  ( 2018-06-19 00:46:16 -0500 )edit
2

The command that solved it for me was:

sudo apt-get install python3-catkin-tools

I was missing the python3 specification.

jeremylevasseur gravatar image jeremylevasseur  ( 2020-09-15 08:03:40 -0500 )edit
1

answered 2021-06-23 18:21:10 -0500

prudhvirajstark gravatar image

catkin: command not found

catkin_make is working for me but "catkin init" or "catkin build" did not work in noetic version ubuntu 20.04.

So I Installed python tools

sudo apt-get install python3-catkin-tools

I got error with "osrf-pycommon" distribution was not found and is required by catkin-tools

so I install osrf-pycommon

sudo apt-get install python3-osrf-pycommon

And Now, catkin is working well and good.

Thanks for the other answers.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-04-20 08:08:23 -0500

Seen: 41,352 times

Last updated: Apr 20 '15