Ask Your Question
1

dynamixel_control no motor found /dynamixel mx-64AR, usb2dynamixel

asked 2015-04-01 09:35:04 -0600

Wine gravatar image

updated 2015-04-03 06:15:13 -0600

Hi guys, I am trying to use the new robotis servo: dynamixel MX-64AR, but I cannot find the servo both in win8 and ubuntu 14.04. in win8, I tried to use RoboPlus Wizard to search all the bps, nothing found... in Ros, I run: roslaunch my_dynamixel_tutorial controller_manager.launch, and I got:

SUMMARY
========

PARAMETERS
 * /dynamixel_manager/namespace: dxl_manager
 * /dynamixel_manager/serial_ports/pan_tilt_port/baud_rate: 57142
 * /dynamixel_manager/serial_ports/pan_tilt_port/max_motor_id: 25
 * /dynamixel_manager/serial_ports/pan_tilt_port/min_motor_id: 0
 * /dynamixel_manager/serial_ports/pan_tilt_port/max_motor_id: 25
 * /dynamixel_manager/serial_ports/pan_tilt_port/update_rate: 20
 * /rosdistro: indigo

 * /rosversion: 1.11.10

NODES
  /
    dynamixel_manager (dynamixel_controllers/controller_manager.py)

auto-starting new master
process[master]: started with pid [23510]
ROS_MASTER_URI=http://localhost:11311

setting /run_id to c01c22cc-d87a-11e4-9915-001aa0aa3777
process[rosout-1]: started with pid [23523]
started core service [/rosout]
process[dynamixel_manager-2]: started with pid [23540]
/opt/ros/indigo/lib/python2.7/dist-packages/dynamixel_driver/dynamixel_serial_proxy.py:92: SyntaxWarning: The publisher should be created with an explicit keyword argument 'queue_size'. Please see http://wiki.ros.org/rospy/Overview/Publishers%20and%20Subscribers for more information.
  self.motor_states_pub = rospy.Publisher('motor_states/%s' % self.port_namespace, MotorStateList)
/opt/ros/indigo/lib/python2.7/dist-packages/dynamixel_driver/dynamixel_serial_proxy.py:93: SyntaxWarning: The publisher should be created with an explicit keyword argument 'queue_size'. Please see http://wiki.ros.org/rospy/Overview/Publishers%20and%20Subscribers for more information.
  self.diagnostics_pub = rospy.Publisher('/diagnostics', DiagnosticArray)

INFO] [WallTime: 1427898245.997934] pan_tilt_port: Pinging motor IDs 0 through 25...

[FATAL] [WallTime: 1427898248.149759] pan_tilt_port: No motors found.

and I am sure of this :

ls -l /dev/ttyUSB0 

crw-rw-rw- 1 root dialout 188, 0  4月  1 22:51 /dev/ttyUSB0 ....

About the HW, I use usb2dynamixel, RS485 -4p interface, and the switcher is in the middle.

the power support is a takasago ex-375l, I set output as 12.5 v, 0.4A, the motor led flashed when it's powered on.

And I had checked the 4p cable, all the four lines are good.

About the ros version;

rosversion dynamixel_controllers

0.4.0

$ dpkg -p ros-indigo-dynamixel-controllers | grep Ver

Version: 0.4.0-0trusty-20150305-1931-+0000

about the bps in the launch file, the parameter of the servo is link:here, the default bps of mx-64ar should be 57142.... I had tried 57142, 57143, 57142.9 and 1000000, no one works.

I am really screwed here....................... HEEEEEEEEEEEEELLLLLLLLLLLPPPPPPP!

edit retag flag offensive close merge delete

Comments

What version of dynamixel package are you using? Add to your original question the following command result for the future refenrence:

$ rosversion dynamixel_controllers
0.4.0
$ dpkg -p ros-indigo-dynamixel-controllers | grep Ver
Version: 0.4.0-0trusty-20150327-0507-+0000
130s gravatar image130s ( 2015-04-03 04:50:24 -0600 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2015-04-03 03:49:16 -0600

Wine gravatar image

Hi guys, finally, I went to the Robotis Shop, and they test my motor and a new mx-64ar and an AX series motor, however, only the AX motor can work. So it seems like that this batch of mx-64ar productions have a lot defectives. What's a bad luck, a defective pesters me 5 days....................

edit flag offensive delete link more

Comments

one more thing just for reminding the followers, with the new mx-64ar I exchanged from the shop, everything works well, but the default baud of this motor is 57143.....if you want to ping it through "controller_manager.launch". note that 57142 doesn't work here, although it works in RoboPlus.

Wine gravatar imageWine ( 2015-04-03 06:46:12 -0600 )edit
0

answered 2015-04-01 14:35:56 -0600

Sietse gravatar image

updated 2015-04-01 14:37:13 -0600

Are you aware that a counterfeit ftdi chip is being used in the usb2dynamixel? Maybe you are struck by this problem. See http://www.m0yom.co.uk/ftdi-serial-ki... for the description and the solution. Worked for me, Sietse

edit flag offensive delete link more

Comments

Thanks for your reply, but I am using mx-64ar, which works with RS485, so I am using RS485 port of USB2dynamixel, not rs232.... which motor are you using ?

Wine gravatar imageWine ( 2015-04-01 21:17:19 -0600 )edit

and also, I tried lsusb, mine is 0403:6001, so it should be something else........

Wine gravatar imageWine ( 2015-04-01 21:58:11 -0600 )edit

I'm using an arm from crustcrawler with ax18a's. Good luck with finding the problem.

Sietse gravatar imageSietse ( 2015-04-02 02:13:33 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-04-01 09:35:04 -0600

Seen: 1,080 times

Last updated: Apr 03 '15