Ask Your Question
0

Why catkin_make doesn't create executables?

asked 2015-03-27 13:46:01 -0500

Romerop gravatar image

updated 2015-03-30 15:07:38 -0500

Maya gravatar image

When I try to build the client-server C++ tutorial with catkin_make it doesn't create any executables, I think I have everything else in order. I had followed every single step in the previous tutorials, the worspace is correctly configured, the CMakeLists.txt seems in order as the package.xml.

Here is the link to the tutorial.http://wiki.ros.org/ROS/Tutorials/WritingServiceClient%28c%2B%2B%29

And the output when I try to build and then execute.

viki@c3po:~$ cd ~/catkin_ws/

viki@c3po:~/catkin_ws$ catkin_make

Base path: /home/viki/catkin_ws
Source space: /home/viki/catkin_ws/src
Build space: /home/viki/catkin_ws/build
Devel space: /home/viki/catkin_ws/devel
Install space: /home/viki/catkin_ws/install
####
#### Running command: "make cmake_check_build_system" in "/home/viki/catkin_ws/build"
####
####
#### Running command: "make -j1 -l1" in "/home/viki/catkin_ws/build"
####

viki@c3po:~$ rosrun beginner_tutorials add_two_ints_server

[rosrun] Couldn't find executable named add_two_ints_server below /home/viki/catkin_ws/src/beginner_tutorials
viki@c3po:~$
edit retag flag offensive close merge delete

Comments

1

This is not enough information to be able to help you. Please edit your question to include a link to the tutorial you're following. Every command you're running and the exact console output, what's in your workspace, and any other relevant information to reproduce your problem. wiki.ros.org/Support

tfoote gravatar image tfoote  ( 2015-03-27 19:02:03 -0500 )edit
1

Could you add your workspace environment variables ? You can have them with export | grep ROS

Maya gravatar image Maya  ( 2015-03-30 15:58:58 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
2

answered 2015-03-30 10:03:39 -0500

The output at the bottom tells you exactly what the problem is. The syntax of rosrun is rosrun PACKAGE EXECUTABLE [ARGS]. You are not providing an executable to rosrun.

edit flag offensive delete link more

Comments

Sorry I wrote that incorrectly, anyway when I write "rosrun begginer_tutorials add_two_ints_server" it says the same thing, add_two_ints_sever is the executable created when building add_two_ints_server.cpp, but the problem is that the executable is never created. Also there is no need of arguments

Romerop gravatar image Romerop  ( 2015-03-30 12:55:20 -0500 )edit

I edited the question so you can see the output when I write the correct command

Romerop gravatar image Romerop  ( 2015-03-30 13:01:27 -0500 )edit
1

answered 2015-03-30 10:20:50 -0500

aak2166 gravatar image

Perhaps you are not adding an executable in your CMakeLists.txt.

Do you have this line in CMakeLists.txt: add_executable(executable_name source_file_name.cpp ?

edit flag offensive delete link more

Comments

Yes I do, as specified in the tutorial. CMakeFile.txt:add_executable(add_two_ints_server src/add_two_ints_server.cpp)

Romerop gravatar image Romerop  ( 2015-03-30 12:59:46 -0500 )edit
0

answered 2015-04-07 02:54:48 -0500

Romerop gravatar image

I couldn't find any answers, so I deleted the Ubuntu image with the ibraries of ROS preinstalled, downloaded another image of Ubuntu and then instaled the libraries and the packages of ROS manually. Now everything seems to work, maybe one of the packages wasn't installed in that image.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-03-27 13:46:01 -0500

Seen: 1,130 times

Last updated: Apr 07 '15