Ask Your Question
1

Rosserial install - missing dependencies

asked 2015-03-23 03:23:54 -0500

khitrir gravatar image

Trying to install Rosserial by following the rosserial_arduino tutorial. Using hydro and ubuntu 12.04.

Every previous step worked fine, but when I get to actually installing the ros_lib using "rosrun rosserial_arduino make_libraries.py ." in ~/sketchbook/libraries, I get a failed to generate warning.

Scrolling up, I have several missing dependency warnings that afaik aren't missing.

There are a several but all but 1 of them are cmake_modules so I'll just copy an example of each type:

    [rqt_rviz]: Unable to find dependency: cmake_modules
ROS path [0]=/opt/ros/hydro/share/ros
ROS path [1]=/home/khitrir/catkin_ws/install/share
ROS path [2]=/home/khitrir/catkin_ws/install/stacks
ROS path [3]=/opt/ros/hydro/share
ROS path [4]=/opt/ros/hydro/stacks. Messages cannot be built.

[xacro]: Unable to find dependency: roslint
ROS path [0]=/opt/ros/hydro/share/ros
ROS path [1]=/home/khitrir/catkin_ws/install/share
ROS path [2]=/home/khitrir/catkin_ws/install/stacks
ROS path [3]=/opt/ros/hydro/share
ROS path [4]=/opt/ros/hydro/stacks. Messages cannot be built.

The actual warning at the end is as follows:

*** Warning, failed to generate libraries for the following packages: ***
image_view (missing dependency)
carrot_planner (missing dependency)
urdf (missing dependency)
rotate_recovery (missing dependency)
navfn (missing dependency)
dwa_local_planner (missing dependency)
robot_state_publisher (missing dependency)
rqt_rviz (missing dependency)
xacro (missing dependency)
clear_costmap_recovery (missing dependency)
move_base (missing dependency)
gazebo_ros (missing dependency)
collada_urdf (missing dependency)
move_slow_and_clear (missing dependency)

I've followed the tutorial closely, and I've found similar questions where the warnings are for different libraries. In there the answer was just incorrect sourcing, but I've matched the tutorial. One suggested ensuring "source /opt/ros/hydro/setup.bash" was run, which I also tried, to no effect.

The commands run for all but the one with the extra source followed this pattern:

cd <ws>/src
git clone https://github.com/ros-drivers/rosserial.git
cd <ws>
catkin_make
catkin_make install
source <ws>/install/setup.bash
cd <sketchbook>/libraries
rosrun rosserial_arduino make_libraries.py .
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-03-23 05:12:05 -0500

gvdhoorn gravatar image

updated 2015-03-24 04:05:22 -0500

Try a rosdep check --from-paths <ws>/src --ignore-src in a shell where you've sourced /opt/ros/hydro/setup.bash.


Edit:

No luck I'm afraid- Running that line I get:

All system dependencies have been satisified

Ok. And what is the output of rospack find cmake_modules after sourcing <ws>/install/setup.bash?


Running find cmake_modules and that definitely seems to be the problem. Result:

[rospack] Error: stack/package cmake_modules not found

Ok. And what is the output of rospack find cmake_modules after sourcing /opt/ros/hydro/setup.bash?

cmake has been functioning normally though?

The cmake_modules pkg only provides additional scripts for CMake. If your pkgs (or any of your dependencies) don't need them, you won't run into any trouble if they are not there. But I doubt they aren't there.

edit flag offensive delete link more

Comments

No luck I'm afraid- Running that line I get:

All system dependencies have been satisified
khitrir gravatar imagekhitrir ( 2015-03-23 10:25:06 -0500 )edit

Running find cmake_modules and that definitely seems to be the problem. Result:

[rospack] Error: stack/package cmake_modules not found

cmake has been functioning normally though?

khitrir gravatar imagekhitrir ( 2015-03-23 21:09:35 -0500 )edit

I'm not sure I understand your last edit - as in the missing dependencies is incorrect? The failed to install message is incorrect or just that as long as i don't need the referenced libraries I can move ahead?

Unfortunately I'm fairly certain I need at least 2 of the failed libraries.

khitrir gravatar imagekhitrir ( 2015-03-26 08:38:20 -0500 )edit

The cmake_modules pkg only provides scripts used by find_package(..) in CMakeLists.txt. If you don't use those scripts, then it would not matter if they were missing (just a response to: "cmake has been functioning normally though").

gvdhoorn gravatar imagegvdhoorn ( 2015-03-26 08:54:32 -0500 )edit

Ah ok. Thanks for the clarification.

Any ideas how to fix the issue cmake_modules?

khitrir gravatar imagekhitrir ( 2015-03-26 19:36:39 -0500 )edit

Well, what is the output of rospack find cmake_modules after sourcing /opt/ros/hydro/setup.bash?

gvdhoorn gravatar imagegvdhoorn ( 2015-03-27 04:49:51 -0500 )edit

That was what I did with "find" before - the result was [rospack] Error: stack/package cmake_modules not found

khitrir gravatar imagekhitrir ( 2015-03-29 03:56:57 -0500 )edit

Pay attention to the setup.bash file sourced. The first question asks to source your catkin_ws/install space, the second to source the ROS Hydro default setup.bash. The output is identical each time? In that case, make sure you have ros-hydro-cmake-modules installed.

gvdhoorn gravatar imagegvdhoorn ( 2015-03-29 05:46:31 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-03-23 03:23:54 -0500

Seen: 1,276 times

Last updated: Mar 24 '15