Ask Your Question
0

Kinect No Image received

asked 2015-03-09 01:24:43 -0600

Coco gravatar image

Hello,i am using ubuntu12.04 and hydro in VMware.i installed openni-camera,openni-launch,and SensorKinect,when I tried to view the data using openni_camera package,

yake@ubuntu:~$ roslaunch openni_camera openni_node.launch

It shows the following message:

[ INFO] [1425880374.263482333]: Number devices connected: 1
[ INFO] [1425880374.264281088]: 1. device on bus 001:17 is a SensorKinect (2bf) from PrimeSense (45e) with serial id '0000000000000000'
[ INFO] [1425880374.266841490]: Searching for device with index = 1
[ INFO] [1425880376.162143780]: Opened 'SensorKinect' on bus 1:17 with serial number '0000000000000000'
[ INFO] [1425880377.080038868]: rgb_frame_id = '/camera_rgb_optical_frame' 
[ INFO] [1425880377.080617873]: depth_frame_id = '/camera_depth_optical_frame'
[ WARN] [1425880377.085363076]: Camera calibration file /home/yake/.ros/camera_info/rgb_0000000000000000.yaml not found.
[ WARN] [1425880377.085733467]: Using default parameters for RGB camera calibration.
[ WARN] [1425880377.086030252]: Camera calibration file /home/yake/.ros/camera_info/depth_0000000000000000.yaml not found.
[ WARN] [1425880377.086327993]: Using default parameters for IR camera calibration.

Output of lsusb:

yake@ubuntu:~$ lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 016: ID 045e:02be Microsoft Corp. 
Bus 002 Device 002: ID 0e0f:0003 VMware, Inc. Virtual Mouse
Bus 002 Device 003: ID 0e0f:0002 VMware, Inc. Virtual USB Hub
Bus 001 Device 017: ID 045e:02bf Microsoft Corp.

To view the video, i therefore run:

$ rosrun image_view image_view image:=/camera/rgb/image_color

but it only have a image windows,have not receive data from kinect.when i run:

$ rosrun image_view disparity_view image:=/camera/depth/disparity

it also have not image data,but we can see the depth camera turn on. Please help me!

edit retag flag offensive close merge delete

Comments

You might need to add some rules in :

etc/udev/rules.d
kokirits gravatar imagekokirits ( 2015-03-09 02:57:35 -0600 )edit

Were you able to view the image in RVIZ? I am having similar issue. I am able to see the image from rosrun rviz rviz command but the rosrun image_view . . . . command is not giving any data, just a blank screen.

rdhn gravatar imagerdhn ( 2015-03-10 01:06:50 -0600 )edit

I can view the image not only in RVIZ but also in image_view.I can not give you specific reason why you only have a blank screen.I guess your image path have some problem if RVIZ can get the image, I suggest that you can follow the book "example by ROS" step by step to execution.

Coco gravatar imageCoco ( 2015-03-12 00:40:53 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-03-11 13:00:30 -0600

BlitherPants gravatar image

Hi,

I had the same problem two years ago. I could never get the Kinect picture to show until I stopped using a virtual machine and set up a dual-boot of Ubuntu.

Here are my steps: http://answers.ros.org/question/63428...

Hope this helps.

edit flag offensive delete link more

Comments

worked for me, I bought a cheap laptop to run the ROS instead of using a vm on my good laptop.

Mr. CEO gravatar imageMr. CEO ( 2015-03-11 13:44:55 -0600 )edit

Thanks,I got the picture when I stopped using Vmware and Wubi.I guess the reason is I can not get the correct drivers when i use Vmware.I got 3 driver when i use a natural Ubuntu12.04.

Coco gravatar imageCoco ( 2015-03-12 00:17:04 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2015-03-09 01:24:43 -0600

Seen: 1,458 times

Last updated: Mar 11 '15