Ask Your Question
0

Using simple_navigation_goals

asked 2015-03-05 07:44:11 -0600

RND gravatar image

updated 2015-03-06 04:06:24 -0600

Hi,

I am in the process of covering this tutorial in order to familiarize myself with the packages of move_base and actionlib. I am aware that the code presented in the tutorial requires move_base server to be run.

My robot platform is a Powerbot (pioneer robot) by ActivMedia Mobilerobots. I am bringing up the following nodes as a standard procedure in order to have my setup up and running:

  1. Roscore
  2. RosAria package to interface and send commands to the robot's microcontroller
  3. Sicktoolbox_wrapper package, to drive the laser range finder
  4. TF transformation to get the followin tf tree: odom -> base_link -> laser

I am also using the move_base.launch that is presented in this repository. Since this requires a map to be fired up, I am using the gmapping package to create the map.

After I run move_base.launch (from the above repository) and the gmapping.launch file, I followed the rest of the tutorial to be able to run a simple command that moves the robot by 1 metre. When i ran the node simple_navigation_goals, I got the following error:

[ERROR] [1425560182.271687421]: Client [/move_base] wants topic /move_base_simple/goal to have datatype/md5sum [geometry_msgs/PoseStamped/d3812c3cbc69362b77dc0b19b345f8f5], but our version has [move_base_msgs/MoveBaseActionGoal/660d6895a1b9a16dce51fbdd9a64a56b]. Dropping connection.
[ INFO] [1425560187.048041843]: Waiting for the move_base action server to come up
[ INFO] [1425560192.048212940]: Waiting for the move_base action server to come up

The move_base action server never seemed to "come up" even though I had run the move_base.launch file.

Also, in the terminal tab where I ran move_base.launch, I had the following, with a warning at the end:

[ INFO] [1425560108.210836103]: Using plugin "static"
[ INFO] [1425560108.359553517]: Requesting the map...
[ INFO] [1425560108.700098618]: Resizing costmap to 4000 X 4000 at 0.050000 m/pix
[ INFO] [1425560108.864587000]: Received a 4000 X 4000 map at 0.050000 m/pix
[ INFO] [1425560108.864730805]: Subscribing to updates
[ INFO] [1425560108.881533417]: Using plugin "inflation"
[ INFO] [1425560109.295686084]: Using plugin "obstacles_laser"
[ INFO] [1425560109.422666966]:     Subscribed to Topics: laser
[ INFO] [1425560109.514106393]: Using plugin "inflation"
[ INFO] [1425560109.778240474]: Created local_planner dwa_local_planner/DWAPlannerROS
[ INFO] [1425560109.795708585]: Sim period is set to 0.20
[ INFO] [1425560110.262923424]: Recovery behavior will clear layer obstacles
[ INFO] [1425560110.412136262]: Recovery behavior will clear layer obstacles
[ WARN] [1425560386.212503542]: Map update loop missed its desired rate of 4.0000Hz... the loop actually took 0.2584 seconds

Can someone please explain to me:

  1. What kind of move_base launch file do I need to have in order to bring up the move_base action server?
  2. Do I need to run other nodes apart from the ones I mentioned previously?
  3. How can I use and run this tutorial (simple_navigation_goals) without having to run gmapping?

EDIT: UPDATE:

This is the procedure that I am following to bring up my setup: 1. roscore 2. rosrun rosaria RosAria _port:=/dev/ttyS0 (runs the rosaria node to drive the robot) 3. rosrun sicktoolbox_wrapper sicklms _port:=/dev/ttyS1 4. rosrun transform transform (TF code brought from this tutorial 5. roslaunch gmapping.launch ... (more)

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-03-05 10:12:19 -0600

IvanV gravatar image

updated 2015-03-09 11:18:59 -0600

How do you launch the simple_navigation_goals node? move_base should listen for actions in move_base/goal topic and for goal poses in move_base_simple/goal. It looks like you have a remap between the two somewhere.

Also, you say you run TF tranformation between map-->odom. Are you publishing this TF by yourself as a static transform? If you are running also gmapping, the map-->odom transformation will be also published by this node.

Regarding the other points:

  1. The one you are running seems good. The warning you are getting doesn't seem important if you are only getting it once.
  2. If you are providing a source of odometry, a map and the map-->odom TF (by gmapping) and the lasers, it should be enough.
  3. You need to set move_base to not use a static map. Try the move_base_mapless_demo.launch from the same repository.

Comments after new edition:

By default, move_base publishes velocities in cmd_vel topic. The launchfile you are using actually remaps this default topic to move_base/cmd_vel. You need to change in move_base.launch (which is called by move_base_mapless_demo.launch) the line:

<remap from="cmd_vel" to="~cmd_vel" />

to

<remap from="cmd_vel" to="/RosAria/cmd_vel" />

so move_base publishes commands in /RosAria/cmd_vel topic.

Regarding the other issues, if move_base is reporting "Got new plan", it seems that action server is working correctly. Fixing the commands topic will probably the robot to move correctly. The frame_id of the goal should be irrelevant, as long as you have a correct tf tree, but if you want just to move forward, it will be more intuitive if it is in base_link.

edit flag offensive delete link more

Comments

When I ran rostopic list I could not see move_base/goal, there was only move_base_simple/goal. Also, the TF is being published by a separate node (I followed this tutorial).

RND gravatar imageRND ( 2015-03-05 10:33:58 -0600 )edit

Also, what is the reason why when I ran simple_navigation_goals, it kept waiting for move_base action server to come up when I had already ran the move_base node in a separate tab of the terminal?

RND gravatar imageRND ( 2015-03-05 10:36:09 -0600 )edit

The tutorials you are following look good. I would go over all the process step by step and see if I was doing something wrong. You can also post here all the launch files and rosrun commands you are using in sequence, so we can help you to check if there is something wrong there.

IvanV gravatar imageIvanV ( 2015-03-06 02:38:03 -0600 )edit

I updated the question to include my most recent developments and where i got stuck now. Thanks for your help.

RND gravatar imageRND ( 2015-03-06 03:31:33 -0600 )edit

also alternative is to remap RosAria/cmd_vel to whatever move_base publishes to, or remap both to some common name. Same result, you can remap whichever topic (input or output) you prefer.

ReedHedges gravatar imageReedHedges ( 2015-03-10 09:29:47 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-03-05 07:44:11 -0600

Seen: 1,191 times

Last updated: Mar 09 '15