ROS not running roscore

asked 2015-03-04 08:48:50 -0500

Aracanid gravatar image

updated 2015-03-05 09:41:36 -0500

I've recently installed indigo on a Raspberry Pi 2. When I try to use roslaunch or rosrun, although it finds the launch file or executable, nothing happens. It doesn't give an error, it just hangs there. I've tried to launch just roscore as well and it produces the same result.

If anyone has any thoughts on what might be causing this I'd appreciate the help :)

Edit: Output of env | grep ROS






edit retag flag offensive close merge delete


This may be a configuration issue - can you update your question with the output of env | grep ROS?

Dan Lazewatsky gravatar image Dan Lazewatsky  ( 2015-03-04 11:27:57 -0500 )edit

Sorry for the delay in replying, I've added the output to env | grep ROS

Aracanid gravatar image Aracanid  ( 2015-03-05 09:13:06 -0500 )edit

Is it actually ROS_PACKAFE_PATH and not ROS_PACKAGE_PATH, or did that somehow get messed up when pasting into your question?

Dan Lazewatsky gravatar image Dan Lazewatsky  ( 2015-03-05 21:21:03 -0500 )edit

I typed it up so it's a typo, my bad :/

Aracanid gravatar image Aracanid  ( 2015-03-09 18:58:09 -0500 )edit

You could try running strace roscore and see if there is any useful output.

Dan Lazewatsky gravatar image Dan Lazewatsky  ( 2015-03-10 17:15:50 -0500 )edit