Ask Your Question
0

how to force hector slam to set robot position ?

asked 2015-02-28 15:12:08 -0500

babaksn gravatar image

updated 2015-02-28 15:13:06 -0500

hi we have a hokuyo laser and in the first seconds of running hector slam specially when the robot's laser data is few(for example in small places)
the robot position has very bad data jumps , but after a while it goes well .
therefore i want to force hector slam to consider and set the robot's position as 0,0 in the first seconds(for example 5 seconds). how can i do this?
i have tried to publish the robot's position to "tf" topic but it didn't work .
also i have launched the hector pose estimiation but it didn't solve the problem.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-02-28 16:07:27 -0500

You can set the robot pose via the (I think undocumented) "/initialpose" topic. This is analogous to how things are done in AMCL. The easiest way to publish to this topic is using rviz and using the "2D Pose Estimate" tool.

edit flag offensive delete link more

Comments

i am publishing the initialpose but the problem of data jumping still remains. is it possible to change the source code to consider robot pose as 0,0 for a while?

babaksn gravatar image babaksn  ( 2015-03-01 08:54:06 -0500 )edit
1

Yes, that's of course possible. The update loop is here https://github.com/tu-darmstadt-ros-p... and could be modified. I apologize for not having the time to give detailed assistance.

Stefan Kohlbrecher gravatar image Stefan Kohlbrecher  ( 2015-03-01 09:09:18 -0500 )edit

thank you . i will figure it out.

babaksn gravatar image babaksn  ( 2015-03-01 10:00:35 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-02-28 15:12:08 -0500

Seen: 830 times

Last updated: Feb 28 '15