Ask Your Question
1

Mesh .dae file with textures invisible

asked 2015-02-24 10:03:55 -0600

End-Effector gravatar image

I created a file .dae with sketchup of a cube with Textures.

I want to put the cube over a pioneer but when I see the robot in Rviz the cube is transparent.

Should I stop using sketchup to generate the .dae and try some other program? Need some help here.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2015-02-25 09:18:34 -0600

End-Effector gravatar image

I MADE IT!

Only took like 1 and a half day.

To add a object with texture to your robot you should use Sketchup to make the thing you want to put in your robot.

Then you have to export it to .obj NOT .dae.

Then open the .obj file with MESHLAB and save it to .dae. You should try opening the file again with meshlab because it gives some crazy error about not having a notexture.png file. Copy random .png file and call it notexture.png.

Then add your mesh to the .urdf file and the folder with the textures. They should be .png textures.

And its done!

image description

edit flag offensive delete link more

Comments

could you please show me the example? (your dae file and urdf file)

yoo gravatar imageyoo ( 2017-10-20 06:25:43 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-02-24 10:03:55 -0600

Seen: 1,270 times

Last updated: Feb 25 '15