Ask Your Question
1

p2os_urdf pioneer3dx bug

asked 2015-02-23 11:26:37 -0600

End-Effector gravatar image

Hello,

I'm trying to simulate a pionner like this one (pionner3dx), but when I run the launch file in the package p2os_urdf. pioneer3dx_urdf.launch I get a bugged robot. The wheel is out of place. I think there is a bad definition on the swife joint. Is probably out of place.

I get he following robot in Rviz.

image description

Paulo.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2015-02-23 11:50:11 -0600

End-Effector gravatar image

I went into the p2os and copied the pioneer3dx.urdf and I used my own launch file and I got a good result. No problem in the URDF file.

image description

edit flag offensive delete link more
1

answered 2015-03-13 10:30:51 -0600

I edited pioneer3dx_body.xacro.

I changed the joint types of base_swivel_joint and swivel_hubcap_joint from continuous to fixed and it solved the same issues I had concerning the center wheel.

To check, I ran the following commands from the urdf wiki:

rosrun xacro xacro.py `rospack find p2os_urdf`/defs/pioneer3dx.xacro > pioneer3dx.urdf
check_urdf pioneer3dx.urdf
urdf_to_graphiz pioneer3dx.urdf
evince pioneer3dx.pdf

Which gave me this: image description

I then ran my robot and used the following commands to check the tf tree:

rosrun tf view_frames
evince frames.pdf

Which gave me this: image description

Checking RViz with Fixed Frame set to odom gave me this: image description

I'll send an email to the maintainer for the p2os repository and see if that is a good fix and have him make updates if they are.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-02-23 11:26:37 -0600

Seen: 167 times

Last updated: Mar 13 '15