Ask Your Question
0

cannot connect to android node

asked 2015-02-21 02:07:50 -0600

rick187 gravatar image

Hi everybody,

I am trying to run ros on an Android device using rosjava. I have first tried downloading the android_sensors_driver app from the Market and everything works fine: I can start a roscore on my laptop and connect to it from the app and I can log all imu/gps data.

However if I try the same with the latest version of the app from the git repo https://github.com/ros-android/androi... it does not work.

I had no problems compiling. When I run the app, I set the master uri with the ip of my laptop and the app says it successfully connected to the master. However when I run rosnode list, I cannot see the app and neither I can see the topics it publishes.

I also tried with the other tutorial apps in https://github.com/rosjava/android_core but they all do the same: they seem to connect to the master, but no node/topic shows up.

I found other people having similar issues and I did these checks/tests: - both the smartphone and the laptop are connected to the same wifi network - both can ping each other - there should be no special firewall in the router and I also tried connecting both devices to a third android device working as a hot spot - I tried different phones

I am using ros indigo and Android kitkat.

Thank you very much for any help. Cheers.

Riccardo

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-03-19 22:19:59 -0600

Daniel Stonier gravatar image

You might have run into this bug which has been fixed in Feb. Does your code utilise this bugfix?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2015-02-21 02:07:50 -0600

Seen: 688 times

Last updated: Mar 19 '15