Ask Your Question
-1

In Eclipse, I'm trying to set a breakpoint, but only getting a 'set bookmark name' popup

asked 2015-02-19 18:10:12 -0500

MikeS gravatar image

Hi Not sure if this is due to mixing Eclipse with ROS, but while trying to set a breakpoint by double clicking in the left border of the editor on a line in my C++ code I keep getting a popup menu for setting a bookmark name. Right mouse clicking in the left border displays a menu to add a bookmark or a task. This occurs both in the C/C++ and Debug perspectives.

I am able to run the program in Eclipse to completion, I would just like to get use to using the debugging facilities before moving on to more complicated stuff.

I have Eclipse v 4.4.1, running on Ubuntu 12.04. and it is setup (through the use of catkin) to develop ROS (hydro) apps as described at http://wiki.ros.org/IDEs#Eclipse

Any suggestions would be appreciated, thanks...

edit retag flag offensive close merge delete

Comments

1

Nothing to do with ROS.

Neil Traft gravatar image Neil Traft  ( 2015-02-22 01:56:08 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-02-21 12:55:36 -0500

MikeS gravatar image

In going back to my development, when I started a debug session, in the upper right hand corner of the debug perspective there is a breakpoints view - this showed that the breakpoints I tried to set actually did get set, even though I didn't get the popup window I was expecting. So, it doesn't work as shown in the tutorials I've seen but it does allow breakpoints. I am considering this solved.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-02-19 18:10:12 -0500

Seen: 1,504 times

Last updated: Feb 21 '15