Ask Your Question
0

Collada (.dae) meshes with unit != "meter" broken?

asked 2015-02-16 05:27:58 -0600

andreasBihlmaier gravatar image

updated 2015-02-16 05:49:17 -0600

Dear community,

I'm having trouble with URDFs that used to work since Hydro. If they contain a collada (.dae) mesh which has <unit> with non meter units (e.g. centimeter):

--- collada_unit_meter.dae      2015-02-16 11:14:28.128423513 +0100
+++ collada_unit_centimeter.dae 2015-02-16 11:16:06.542388857 +0100
@@ -7,7 +7,7 @@
     </contributor>
     <created>2015-02-16T11:14:28</created>
     <modified>2015-02-16T11:14:28</modified>
-    <unit name="meter" meter="1"/>
+    <unit name="centimeter" meter="0.01"/>
     <up_axis>Z_UP</up_axis>
   </asset>
   <library_images/>
@@ -97,4 +97,4 @@
   <scene>
     <instance_visual_scene url="#Scene"/>
   </scene>
-</COLLADA>
\ No newline at end of file
+</COLLADA>

no mesh at all is displayed in rviz RobotModel. It seems the mesh is also ignored for MoveIt! collision checking.

Test files can be created by simply exporting the default cube as .dae in Blender. Once without modification and once with modified . These files can also be found here: https://gist.github.com/andreasBihlma...

Can anybody confirm this issue?

Regards, ahb

Addition: The same meshes (with unit != meter) worked fine and continue to work fine with gazebo. Actually, I convert the .sdf to .urdf using pysdf.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-02-16 05:41:58 -0600

updated 2015-02-16 05:45:14 -0600

Sounds like a regression to me, you should probably file a bug ticket for rviz. The fact that things ceased working also for moveit suggests a broader issue with how mesh loading works, however. Hopefully, a issue on rviz will trigger the necessary discussion of this.

While I can't confirm your issue directly, I also noticed changes in COLLADA handling between hydro and indigo. I encountered another issue where rendering didn't work in hydro, but did so in indigo (see drcsim Bitbucket #466).

edit flag offensive delete link more

Comments

I was not sure where to file the bug (rviz, urdfdom, ...), thus I wanted to ask here before.

andreasBihlmaier gravatar imageandreasBihlmaier ( 2015-02-16 05:47:47 -0600 )edit

I can confirm this issue. Meshes get loaded fine without any error message, but nothing is displayed. Re-exporting such that the unit is meter seems to be the only remedy. These are meshes that worked fine in rviz hydro.

demmeln gravatar imagedemmeln ( 2015-02-23 09:23:57 -0600 )edit

These test meshes do not work for me with current ros indigo from apt on ubuntu 14.04: https://github.com/garaemon/rviz_coll...

demmeln gravatar imagedemmeln ( 2015-02-23 09:30:35 -0600 )edit

Against which repository should we fill a bug report?

andreasBihlmaier gravatar imageandreasBihlmaier ( 2015-02-24 02:56:24 -0600 )edit
demmeln gravatar imagedemmeln ( 2015-02-24 13:55:37 -0600 )edit

Yes, please open an issue on rviz, and include what version you are using and the example repository you have linked in the original question.

William gravatar imageWilliam ( 2015-02-25 00:47:24 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

3 followers

Stats

Asked: 2015-02-16 05:27:58 -0600

Seen: 600 times

Last updated: Feb 16 '15