Ask Your Question
0

Installing ROS Indigo by source catkin building error

asked 2015-02-09 11:45:12 -0500

NRW_ROS gravatar image

Hello,

I´m following this tutorial to install ROS Indigo by Source on Ubuntu 14.04: http://wiki.ros.org/indigo/Installati...

Everything worked until that point: 2.1.3 Building the catkin Workspace

Using this command to build catkin Workspace: $ ./src/catkin/bin/catkin_make_isolated --install -DCMAKE_BUILD_TYPE=Release

occurs in the following error message:

==> Processing catkin package: 'catkin'
==> cmake /home/ROSproject/ros_catkin_ws/src/catkin -DCATKIN_DEVEL_PREFIX=/home/ROSproject/ros_catkin_ws/devel_isolated/catkin -DCMAKE_INSTALL_PREFIX=/home/ROSproject/ros_catkin_ws/install_isolated -DCMAKE_BUILD_TYPE=Release -G Unix Makefiles in '/home/ROSproject/ros_catkin_ws/build_isolated/catkin'

Unhandled exception of type 'OSError':

Traceback (most recent call last):

File "src/catkin/bin/../python/catkin/builder.py", line 919, in build_workspace_isolated number=index + 1, of=len(ordered_packages)

File "src/catkin/bin/../python/catkin/builder.py", line 655, in build_package destdir=destdir, use_ninja=use_ninja

File "src/catkin/bin/../python/catkin/builder.py", line 390, in build_catkin_package run_command_colorized(cmake_cmd, build_dir, quiet, add_env=add_env)

File "src/catkin/bin/../python/catkin/builder.py", line 181, in run_command_colorized run_command(cmd, cwd, quiet=quiet, colorize=True, add_env=add_env)

File "src/catkin/bin/../python/catkin/builder.py", line 199, in run_command raise OSError("Failed command '%s': %s" % (cmd, e))

OSError: Failed command '['cmake', '/home/ROSproject/ros_catkin_ws/src/catkin', '-DCATKIN_DEVEL_PREFIX=/home/ROSproject/ros_catkin_ws/devel_isolated/catkin', '-DCMAKE_INSTALL_PREFIX=/home/ROSproject/ros_catkin_ws/install_isolated', '-DCMAKE_BUILD_TYPE=Release', '-G', 'Unix Makefiles']': [Errno 2] No such file or directory

<== Failed to process package 'catkin':
Failed command '['cmake', '/home/ROSproject/ros_catkin_ws/src/catkin', '-DCATKIN_DEVEL_PREFIX=/home/ROSproject/ros_catkin_ws/devel_isolated/catkin', '-DCMAKE_INSTALL_PREFIX=/home/ROSproject/ros_catkin_ws/install_isolated', '-DCMAKE_BUILD_TYPE=Release', '-G', 'Unix Makefiles']': [Errno 2] No such file or directory
Command failed, exiting.

Thanks for help in advance!

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
2

answered 2015-02-09 15:26:16 -0500

William gravatar image

Judging from the error, it looks like you may not have cmake installed? Did you successfully run the rosdep install ... step in the tutorial?

A work around will be to install cmake, and since you're on Ubuntu you can just do sudo apt-get install cmake, but if cmake was not installed, then it is likely other things which need to be installed are not.

Also, if you were not aware, there are binary packages for Indigo on 14.04 on i386 and amd64, so unless you have a specific reason for compiling from source, you can just sudo apt-get install ros-indigo-... for your packages.

edit flag offensive delete link more

Comments

On behalf of @NRW_ROS: You were right. There were some deps missing from rosdep install ... . I forced the installation and it works now. Thanks a lot!

William gravatar image William  ( 2015-02-10 12:42:53 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-02-09 11:45:12 -0500

Seen: 2,905 times

Last updated: Feb 09 '15