ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Blocked on the install tutorial : naoqi_driver not found

asked 2015-02-03 04:45:07 -0500

P-A gravatar image


I have followed those tutorials : in order to install NaoQI on a remote PC.

I work on Ubuntu 12.04 with ROS hydro. NaoQI version is 1.14.3 and pynaoqi is 1.12.5 on linux 64 bits.

I have chosen the Ubuntu-packages method and have installed ros-hydro-nao-robot. All was going well but the command LD_LIBRARY_PATH=/home/devtools/naoqi-sdk-1.14.3-linux64/lib:$LD_LIBRARY_PATH NAO_IP= roslaunch nao_driver nao_driver_sim.launch returns

[nao_driver_sim.launch] is neither a launch file in package [nao_driver] nor is [nao_driver] a launch file name

I think this problem is linked to an error I get when launching roslaunch nao_bringup nao.launch and which returns

ERROR: cannot launch node of type [naoqi_driver/naoqi_joint_states_cpp]: can't locate node [naoqi_joint_states_cpp] > in package [naoqi_driver]

I didn't find any answer to my problem on the forum (even if some are really close).

Do you have an idea of what to do to solve this problem ?

Thank you very much,

edit retag flag offensive close merge delete


I am running into the exact same issue. However, I am running on Ubuntu 14.04 with ROS indigo and NaoQi 1.14.5 on linux 64 bits. Interestingly enough when I change nao_driver to naoqi_driver and nao_driver_sim.launch to naoqi_driver_sim.launch I am getting the error: ERROR: cannot launch node of type [naoqi_driver/naoqi_joint_states_cpp]: can't locate node [naoqi_joint_states_cpp] in package [naoqi_driver]

evenmarbles gravatar image evenmarbles  ( 2015-02-04 01:24:54 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2015-02-04 04:09:58 -0500

evenmarbles gravatar image

So I think I may have actually figured something out.

First of all, as is stated here the Getting Started page is pretty outdated. So is apparently the documentation of naoqi_driver . Interesting to note is that the repositories shown at when compiling from source are actually different ones. Where the one given in the sample ( ) which is outdated. When you follow that link you will see that it is to be deleted. So the binaries are actually pulled from this repository: . When you dig a little in the code you will see that quite a lot has changed. So there is no more nao_driver_sim.launch for example but instead only a naoqi_driver.launch.

As mentioned in my comment earlier when using naoqi_driver.launch I would get the following error:

ERROR: cannot launch node of type [naoqi_driver/naoqi_joint_states_cpp]: can't locate node [naoqi_joint_states_cpp] in package [naoqi_driver]

I was able to get around this error by attaching force_python:=true to the whole command:

$ LD_LIBRARY_PATH=~/naoqi/naoqi-sdk-1.14.5-linux64/lib:$LD_LIBRARY_PATH NAO_IP= roslaunch nao_bringup nao_full.launch **force_python:=true**

This here works as well, but you get more nodes running with the previous call:

$ LD_LIBRARY_PATH=~/naoqi/naoqi-sdk-1.14.5-linux64/lib:$LD_LIBRARY_PATH NAO_IP= roslaunch naoqi_driver naoqi_driver.launch force_python:=true

When you call rosnode list you will see the nodes running are different now. BTW, I found the nao_walker under nao_apps. So you would have to call that separately. It would be nice if someone who actually knows what they are doing could document that properly (today was my first day messing around with ROS... with all these issues a pretty steep curve).

One more thing: with my "fix" there seems to be some problems with the ALAudioDevice proxy. It couldn't be created. I wonder if that has to do with the fact that I am running it in simulation rather than on the real robot...

Well I hope that will help you. I am by no means no expert in all things concerning ROS. And maybe someone with ROS experience has some more insight of what is going on.

edit flag offensive delete link more

answered 2015-02-04 10:36:25 -0500

P-A gravatar image

updated 2015-02-04 10:39:26 -0500

Thank you very much evenmarbles ! I have 2 configurations :

  • Ubuntu 14.04, with ROS indigo, naoqi-sdk- and pynaoqi on linux 64
  • Ubuntu 12.04 with ROS hydro, naoqi-sdk 1.14.3 and pynaoqi 1.12.15 on linux64.

Your solution worked on both (no stars around force-python:=true). I have just got some warnings with the microphone. When I looked on the files on opt/ros/hydro/share, I noticed there was no cpp package for the joint_positions, but only a .py one : that's why force-python:=true works. It forces the python's file use (written in the launch file).

I have the same problem as you with the ALAudioDevice proxy, but I have launched the nodes on a real NAO, and the problem disappeared. So this is because no audio is available on a simulated NaoQi.

As you noticed, it seems that the documentation is not up-to-date anymore. I am not well-qualified to update it (I just begin to work with nao). But if anyone could do this, I would be very grateful !

Just another question : have you succeed to get an image from the cameras (naoqi_sensors camera.launch) ?

edit flag offensive delete link more


Hi there!

I tried and it worked for me without any problems. You have to start rviz and there subscribe to the topic.

gergely.magyar gravatar image gergely.magyar  ( 2015-02-19 07:57:54 -0500 )edit

Question Tools



Asked: 2015-02-03 04:45:07 -0500

Seen: 1,254 times

Last updated: Feb 04 '15