Ask Your Question
0

Move_base error: Local costmap doesn't work (robot unable to do obstacle avoidance)

asked 2015-01-29 18:27:09 -0500

jwang gravatar image

Hi!

I am using Hydro on Ubuntu 12.04. I have tried the turtlebot_simulation tutorials and all went well. I am using Kobuki robot but I have changed the laser scanner input from the kinect to a laser. The laser seems to be correct as I can see the laser in RVIZ. However, when I launch move_base, the local costmap does not seem to be reading the laser and hence the robot fails to avoid obstacles that are not on the map. The global costmap shows correctly, but there is no local costmap. I am using 100% the same settings as in turtlebot_navigation package - the only difference is that I have a laser model instead of the Kinect.

I have tried the following reference, but it still does not work.

http://answers.ros.org/question/12849...

Any ideas? Thanks!

edit retag flag offensive close merge delete

Comments

Are you able to visualize the local costmap in Rviz?

David Lu gravatar imageDavid Lu ( 2015-01-30 10:30:45 -0500 )edit

There is no local costmap in Rviz, only global costmap can been seen.

jwang gravatar imagejwang ( 2015-01-30 10:40:39 -0500 )edit

Change the local_costmap update_frequency parameter to 1.0 and try again.

David Lu gravatar imageDavid Lu ( 2015-01-30 12:06:34 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
3

answered 2015-01-30 12:54:13 -0500

jwang gravatar image

I figured out that after I change the min_obstacle_height of the laser from 0.25 to 0.0 in costmap_commom_params.yaml, the obstacles can be shown in the costmap now. And the robot can do obstacle avoidance. Still thank you for your reply!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-01-29 18:27:09 -0500

Seen: 866 times

Last updated: Jan 29 '15