Ask Your Question
2

Raspberry pi -Unable to locate package ros-indigo-ros-tutorials

asked 2015-01-20 23:15:11 -0500

blackey gravatar image

updated 2015-01-20 23:31:31 -0500

130s gravatar image

Hello everyone, I am trying to follow the tutorials in wiki to install the ROS and learn something about it. I had successfully installed the ROS following the instructions here http://wiki.ros.org/ROSberryPi/Instal... . Then I tried to learn some basic knowledge about it in tutorials. But when I came to this part http://wiki.ros.org/ROS/Tutorials/Und... , and I type sudo apt-get install ros-indigo-ros-tutorials and it returns Unable to locate package ros-indigo-ros-tutorials. Well then I kept going because I can see the turtle in the monitor. But when I came to the next part, and i requires me to install ros-indigo-rqt, and it still returns unable to locate package.

So I think maybe someone can help me out?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-07-08 16:50:39 -0500

Chickenman gravatar image

I had the same problem. Found a solution in the end of tutorial you linked. You have to change the name of the packages

$ cd ~/ros_catkin_ws

$ rosinstall_generator ros_tutorials --rosdistro indigo --deps --wet-only --exclude roslisp --tar > indigo-custom_ros.rosinstall

Next, update the workspace with wstool:

$ wstool merge -t src indigo-custom_ros.rosinstall
$ wstool update -t src

it downloaded the package for me but you have to add ros_catkin_ws to workspace path

now I have a new problem when i am trying to run rosrun turtlesim turtlesim_node I am getting this message

[rosrun] Couldn't find executable named turtlesim_node below /home/pi/ros_catkin_ws/src/ros_tutorials/turtlesim

edit flag offensive delete link more

Comments

Ok i am updating my status my turtlesim is working properly now without any problems if you have any questions feel free to ask maybe i would be able to help btw sorry for my bad english :)

Chickenman gravatar image Chickenman  ( 2015-07-08 17:48:23 -0500 )edit

Can u tell me how u did this ?

Grzybek gravatar image Grzybek  ( 2015-10-23 14:03:54 -0500 )edit

Can you install tutorial packages or which error message do you get. I gave you commands for installing tutorial packages. It worked for me.

Chickenman gravatar image Chickenman  ( 2015-10-23 16:35:05 -0500 )edit

I had a problem with install but I did this with your commands. Now i have problem with turltesim_nodes

Grzybek gravatar image Grzybek  ( 2015-10-23 16:53:56 -0500 )edit

Did you ran catkin_make ?

Try this command and send me what you got from console you probably did not setup your workspace correctly.

$ printenv | grep ROS

And tell me where is your ros_catkin_ws My is at /home/pi/ros_catkin_ws

Chickenman gravatar image Chickenman  ( 2015-10-24 05:33:38 -0500 )edit

`ROS_ROOT=/opt/ros/indigo/share/ros ROS_PACKAGE_PATH=/home/pi/catkin_ws/src:/opt/ros/indigo/share:/opt/ros/indigo/stacks ROS_MASTER_URI=http://localhost:11311 ROS_DISTRO=indigo ROS_ETC_DIR=/opt/ros/indigo/etc/ros My ros_catkin_ws is the same place where yours.

Grzybek gravatar image Grzybek  ( 2015-10-24 06:33:41 -0500 )edit

And when i try use catkin_make in ros_catkin_ws i have pi@~/ros_catkin_ws $ catkin_make Base path: /home/pi/ros_catkin_ws Source space: /home/pi/ros_catkin_ws/src The specified base path "/home/pi/ros_catkin_ws" contains a CMakeLists.txt but "catkin_make" must be invoked in the the root of workspace

Grzybek gravatar image Grzybek  ( 2015-10-24 06:44:15 -0500 )edit

ok so open your .bashrc file

$ cd
$ nano .bashrc

and put this two lines of text at the end of the file

source /opt/ros/indigo/setup.bash

source ~/ros_catkin_ws/devel/setup.bash

and save the file restart your console and try catkin_make or running the turtlesim

Chickenman gravatar image Chickenman  ( 2015-10-24 07:28:59 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2015-01-20 23:15:11 -0500

Seen: 3,204 times

Last updated: Jul 08 '15