Ask Your Question
0

Gazebo won't launch without restarting PC

asked 2015-01-19 13:10:04 -0600

Oguz gravatar image

updated 2015-01-19 14:11:47 -0600

I've been following the tutorials of GazeboSim. I can spawn the 'RRBot' with roslaunch rrbot_gazebo rrbot_world.launch command, but if I close Gazebo, I cannot spawn the RRBot again, instead, encounter with this output;

URDF in parameter [/robot_description] on the ROS param server. Segmentation fault (core dumped) [gazebo-2] process has died [pid 5212, exit code 139, cmd /opt/ros/hydro/lib/gazebo_ros/gzserver /home/oguzhan/catkin_ws/src/gazebo_ros_demos/rrbot_gazebo/worlds/rrbot.world __name:=gazebo __log:=/home/oguzhan/.ros/log/4c41b0c0-a00c-11e4-837b-40f02ffcf6f4/gazebo-2.log]. log file: /home/oguzhan/.ros/log/4c41b0c0-a00c-11e4-837b-40f02ffcf6f4/gazebo-2.log [urdf_spawner-4] process has finished cleanly log file: /home/oguzhan/.ros/log/4c41b0c0-a00c-11e4-837b-40f02ffcf6f4/urdf_spawner-4*.log


If I restart my PC, I can spawn the RRBot again with the same command ' roslaunch rrbot_gazebo rrbot_world.launch '. Again, if I shut it down, I cannot spawn again, but

I tried to kill the process, killall gzserver and pkill gzserver but it didn't help. I checked the System Monitor to see if any remaining process running, but it didn't also help.

But after these, I can launch gazebo standalone with no problem and also, I can launch gazebo with roslaunch gazebo_ros empty_world.launch and I can spawn the Baxter robot with rosrun gazebo_ros spawn_model -file rospack find baxter_description/urdf/baxter.urdf -urdf -z 1 -model baxter

But I still fail to spawn the RRBOT with roslaunch rrbot_gazebo rrbot_world.launch

Do you have any ideas?

edit retag flag offensive close merge delete

4 Answers

Sort by ยป oldest newest most voted
0

answered 2015-02-03 15:39:24 -0600

Oguz gravatar image

updated 2015-02-03 15:41:32 -0600

Problem solved: In rrbot_world.launch file, I commented out:

<!--<arg name="world_name" value="$(find rrbot_gazebo)/worlds/rrbot.world"/> -->

and it is now working without any problem.

edit flag offensive delete link more
0

answered 2015-01-20 08:09:54 -0600

Dash gravatar image

Thanks. The gazebo log shows nothing. After reread the segfault message.. Looks like its the ursf_spawner script that's aegfaulting. Can you check the log file for that? (Its path is in the segfault message)

edit flag offensive delete link more

Comments

I edited my answer with the urdf_spawner log file that you requested. I started thinking on building my own URDF from SolidWorks and go on tutorials from there, this file also doesn't seem to give any clue...

Oguz gravatar imageOguz ( 2015-01-21 10:52:28 -0600 )edit
0

answered 2015-01-20 04:43:01 -0600

Oguz gravatar image

updated 2015-01-21 10:50:06 -0600

Edit, urdf_spawner-4 lof file. Ridiculous that it shuts down after succesfuly spawned the model.;

[rospy.client][INFO] 2015-01-21 18:43:40,170: init_node, name[/urdf_spawner], pid[12012]
[xmlrpc][INFO] 2015-01-21 18:43:40,170: XML-RPC server binding to 0.0.0.0:0
[xmlrpc][INFO] 2015-01-21 18:43:40,171: Started XML-RPC server [http://oguzhan-SATELLITE-L50-A-1CZ:59295/]
[rospy.init][INFO] 2015-01-21 18:43:40,171: ROS Slave URI: [http://oguzhan-SATELLITE-L50-A-1CZ:59295/]
[rospy.impl.masterslave][INFO] 2015-01-21 18:43:40,171: _ready: http://oguzhan-SATELLITE-L50-A-1CZ:59295/
[xmlrpc][INFO] 2015-01-21 18:43:40,171: xml rpc node: starting XML-RPC server
[rospy.registration][INFO] 2015-01-21 18:43:40,172: Registering with master node http://localhost:11311
[rospy.init][INFO] 2015-01-21 18:43:40,271: registered with master
[rospy.rosout][INFO] 2015-01-21 18:43:40,271: initializing /rosout core topic
[rospy.rosout][INFO] 2015-01-21 18:43:40,273: connected to core topic /rosout
[rospy.simtime][INFO] 2015-01-21 18:43:40,274: initializing /clock core topic
[rospy.simtime][INFO] 2015-01-21 18:43:40,276: connected to core topic /clock
[rosout][INFO] 2015-01-21 18:43:40,278: Loading model xml from ros parameter
[rosout][INFO] 2015-01-21 18:43:40,281: Waiting for service /gazebo/spawn_urdf_model
[rosout][INFO] 2015-01-21 18:43:40,282: Calling service /gazebo/spawn_urdf_model
[rospy.internal][INFO] 2015-01-21 18:43:40,287: topic[/clock] adding connection to [http://oguzhan-SATELLITE-L50-A-1CZ:54499/], count 0
[rospy.internal][INFO] 2015-01-21 18:43:40,524: topic[/rosout] adding connection to [/rosout], count 0
[rosout][INFO] 2015-01-21 18:43:40,649: Spawn status: SpawnModel: Successfully spawned model
[rospy.core][INFO] 2015-01-21 18:43:40,650: signal_shutdown [atexit]
[rospy.internal][INFO] 2015-01-21 18:43:40,654: topic[/rosout] removing connection to /rosout
[rospy.internal][INFO] 2015-01-21 18:43:40,654: topic[/clock] removing connection to http://oguzhan-SATELLITE-L50-A-1CZ:54499/
[rospy.impl.masterslave][INFO] 2015-01-21 18:43:40,654: atexit

I started PR2 simulator tutorials and I can spawn PR2 with no problem, without needing to restart.

edit flag offensive delete link more
0

answered 2015-01-19 15:29:43 -0600

DevonW gravatar image

updated 2015-01-19 15:30:12 -0600

What's inside the gzlog? It can be found at ~/.gazebo/gzserver.log

Please post back with the contents of that log and I can help you further.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-01-19 13:01:33 -0600

Seen: 1,308 times

Last updated: Jan 21 '15