Ask Your Question
0

No data from applanix_driver

asked 2015-01-16 19:46:08 -0500

ahendrix gravatar image

I'm trying to use the applanix_driver package with an Applanix POS-LV 120, and it doesn't appear to be producing any output.

I have my network set up properly, and I can ping the applanix. When I run the bridge node, it looks like it connects properly:

$ rosrun applanix_bridge bridge 
[INFO] [WallTime: 1421457951.235263] Successfully connected to data port at 192.168.53.100:5602
[INFO] [WallTime: 1421457951.236802] Successfully connected to control port at 192.168.53.100:5601
[INFO] [WallTime: 1421457951.238069] Port control thread started.
[INFO] [WallTime: 1421457951.238975] Port data thread started.

I see that there are lots of topics published, but I don't get any data if I subscribe to most of them. The only topic with data appears to be the /subscribed_groups topic:

groups: [1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 10007, 12, 13, 10008, 15, 10001, 10002, 10003, 10004, 10005, 10006, 23, 24, 10009, 22, 10011, 10012, 26, 30, 31, 32, 33, 11, 14, 99, 17, 25, 20, 21]

I get similar results when running the applanix_bridge example.launch file

If I connect my appanix to a Windows machine running Applanix's POSView software, I can see that it's active and sending data, and I've configured it for automatic startup mode, so that it goes straight into the Navigating mode on startup.

If I run tcpdump or wireshark alongside the applanix_bridge node on my ROS machine, I see UDP traffic on port 5600, and TCP traffic on port 5601, and it seems to contain some kind of data.

Further, I've tried running the applanix_bridge diagnostics_publisher node, but it also does not publish any output.

I'm using the hydro-devel branch of applanix_driver with ROS Indigo on Ubuntu 14.04

What am I missing?

edit retag flag offensive close merge delete

Comments

I don't know if anyone here has tried the driver on Indigo. Would it be possible for you to post a pcap file?

Ryan gravatar image Ryan  ( 2015-01-17 11:29:36 -0500 )edit

I'll get a pcap file and attach it when I'm back at work on Tuesday (Monday is a holiday here in the US)

ahendrix gravatar image ahendrix  ( 2015-01-17 18:18:56 -0500 )edit

I seem to be having somewhat of a similar problem.

I get some data (the driver actually complains about getting messages it doesn't recognise) but then it seems to timeout. I have also connected to the 5601 and 5602 ports using netcat and there is definitely a lot of data ther See attached trace

tge gravatar image tge  ( 2016-10-18 05:51:43 -0500 )edit

I cant seem to attach or paste code due to message length limits.Traceback:

File "/home/osboxes/catkin_ws/install/lib/python2.7/dist-packages/applanix_bridge/translator.py", line 102, in deserialize if st == '': raise EndOfBuffer() EndOfBuffer

tge gravatar image tge  ( 2016-10-18 05:53:31 -0500 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2015-01-17 15:07:02 -0500

Unfortunately, the diagnostic publisher node only republishes data from the unit itself— it contains no information about the state of the connection to the device itself.

If you're seeing UDP data on port 5600, that may mean this device is configured a little differently from the ones we have worked with, where the data turns up on 5602 and 5603. If you change the realtime port to 5600 in bridge.py, do you get better results?

If so, we'd welcome a PR which properly parameterizes this.

edit flag offensive delete link more

Comments

Hrm... I think 5600 might be the 1Hz status port or something. Do I need to configure the realtime port separately? The applanix_driver page doesn't mention any specific configuration settings that I should set.

ahendrix gravatar image ahendrix  ( 2015-01-17 18:18:20 -0500 )edit

It should be on by default, but possibly your receiver requires it be specifically enabled.

mikepurvis gravatar image mikepurvis  ( 2015-01-23 10:22:48 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-01-16 19:46:08 -0500

Seen: 287 times

Last updated: Jan 17 '15