Ask Your Question
0

rosserial_arduino failed to generate libraries for packages

asked 2015-01-09 14:08:18 -0500

pnyholm gravatar image

I am following the tutorials for rosserial_arduino and when I run

rosrun rosserial_arduino make_libraries.py

I get the error:

*** Warning, failed to generate libraries for the following packages: ***
map_msgs
relative_nav_msgs

I don't care about the map_msgs, but the relative_nav_msgs are custom message types that I need.

It looks like it breaks part way through the messages, this is the exact formatted output

Exporting relative_nav_msgs
Messages:
  Path,FilterState,Waypoint,Snapshot,Goal,DesiredVector,NodeInfo,Keyframe,Voltage,DEBUG_Controller,PartialState,Exporting turtle_actionlib

So it looks like something bad happened after the PartialState message and it skipped to Exporting the turtle_action lib.

Also, is there a way to turn off which types are built? For example, I don't actually care about the map_msgs, can I omit them from ros_lib?

edit retag flag offensive close merge delete

Comments

Did you already try this?

Andromeda gravatar image Andromeda  ( 2015-01-10 16:06:40 -0500 )edit

Yes, I have tried that but then it doesn't include my custom messages directory

pnyholm gravatar image pnyholm  ( 2015-01-12 15:43:23 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-01-12 15:44:31 -0500

pnyholm gravatar image

It turns out the messages it cannot create headers for are the custom messages that are made of custom messages. My work around is to delete all of those types of messages and only create headers for the message I am interested in, which is made of floats. I will ask this question in a new thread.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2015-01-09 14:08:18 -0500

Seen: 356 times

Last updated: Jan 12 '15