Ask Your Question
1

Download and install openslam_gmapping

asked 2015-01-08 11:11:26 -0600

RND gravatar image

updated 2015-01-09 02:17:41 -0600

Hi,

I am a beginner to ROS and I have successfully downloaded ROS Indigo. I am using Ubuntu as my OS. I would like to install the package openslam_gmapping on ROS from the source : https://github.com/ros-perception/ope... .

I have been following tutorials to familiarize myself with ROS, among them, I followed this post to attempt to download and install a package: http://answers.ros.org/answers/115386...

Installing hector_slam from the above post was successful and I even managed to run it. However, when I followed the steps of the same post to install and run openslam_gmapping, I was presented with a lot of errors, among them:

rachdar@ubuntu:~$ source /opt/ros/indigo/setup.bash
rachdar@ubuntu:~$ mkdir slam_gmapping
mkdir: cannot create directory ‘slam_gmapping’: File exists
rachdar@ubuntu:~$ mkdir slam_gmapping
rachdar@ubuntu:~$ cd slam_gmapping
rachdar@ubuntu:~/slam_gmapping$ wstool init
Writing /home/rachdar/slam_gmapping/.rosinstall

update complete.
rachdar@ubuntu:~/slam_gmapping$ wstool merge slam_gmapping_catkin.rosinstall
     Performing actions: 

     Add new elements:
  src/slam_gmapping

Config changed, maybe you need run wstool update to update SCM entries.
Overwriting /home/rachdar/slam_gmapping/.rosinstall

update complete.
rachdar@ubuntu:~/slam_gmapping$ wstool update
[src/slam_gmapping] Fetching https://github.com/ros-perception/slam_gmapping.git (version catkin) to /home/rachdar/slam_gmapping/src/slam_gmapping
Cloning into '/home/rachdar/slam_gmapping/src/slam_gmapping'...
remote: Counting objects: 605, done.
remote: Total 605 (delta 0), reused 0 (delta 0)
Receiving objects: 100% (605/605), 112.05 KiB | 0 bytes/s, done.
Resolving deltas: 100% (278/278), done.
Checking connectivity... done.
WARNING [vcstools] Command failed: 'git checkout catkin'
 run at: '/home/rachdar/slam_gmapping/src/slam_gmapping'
 errcode: 1:
error: pathspec 'catkin' did not match any file(s) known to git.
[/vcstools]
Exception caught during install: Error processing 'src/slam_gmapping' : [src/slam_gmapping] Checkout of https://github.com/ros-perception/slam_gmapping.git version catkin into /home/rachdar/slam_gmapping/src/slam_gmapping failed.

ERROR in config: Error processing 'src/slam_gmapping' : [src/slam_gmapping] Checkout of https://github.com/ros-perception/slam_gmapping.git version catkin into /home/rachdar/slam_gmapping/src/slam_gmapping failed.

I don't know what these errors mean. Can someone help please? Thanks a lot!

I am creating this .rosinstall file in gedit text editor:

- git:
    uri: https://github.com/ros-perception/slam_gmapping.git
    local-name: src/slam_gmapping
    version: catkin
edit retag flag offensive close merge delete

Comments

It looks like you have a bogus entry in your .rosinstall file of your workspace. Can you post it? How did you change your workspace to include slam_gmapping? What commands did you run to get this error, e.g. wstool?

William gravatar imageWilliam ( 2015-01-08 12:33:58 -0600 )edit

Please edit your question to include longer content like this, comments are not suited for this purpose.

William gravatar imageWilliam ( 2015-01-08 13:41:37 -0600 )edit

You should not be using rosws with catkin, you should instead use wstool , see: http://wiki.ros.org/wstool

William gravatar imageWilliam ( 2015-01-08 13:47:07 -0600 )edit

yes, you're right. Thanks I will try to use wstool and follow this procedure:

1) mkdir <folder> 2) cd <folder> 3) wstool init 4) wstool merge <the rosinstall="" file="" responsible="" for="" the="" source="" url=""> 5) wstool update

is this correct? I have added the full code in the question. Thanks a lot!

RND gravatar imageRND ( 2015-01-09 01:44:50 -0600 )edit

I tried working with wstool but I got the same error. I updated my question with the code I'm using and the .rosinstall file im creating in a text editor. I'd appreciate any help since I'm extremely new to this and I need ROS for my project! Thanks a lot!!

RND gravatar imageRND ( 2015-01-09 02:18:57 -0600 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2018-08-08 04:24:06 -0600

Subodh Malgonde gravatar image

The ROS package slam_gmappingdepends on another package openslam_gmapping. As of this writing, if you are on melodic distro, you need to install these packages from source since they are not released into melodic yet. For ROS packages installing from source implies cloning their repositories in the src directory of your workspace.

cd your_work_space/src
git clone https://github.com/ros-perception/slam_gmapping.git
git clone https://github.com/ros-perception/openslam_gmapping.git

# [comment] navigate back to your_work_space directory
cd ..

Next, Install missing dependencies if any:

rosdep install --from-paths src --ignore-src

Next: Build your project

catkin_make
edit flag offensive delete link more

Comments

It worked!

Thank you very much for your answer

Esaú Ortiz gravatar imageEsaú Ortiz ( 2018-12-08 10:58:41 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2015-01-08 11:11:26 -0600

Seen: 2,138 times

Last updated: Aug 08 '18