Ask Your Question
0

ROS master URI is not set

asked 2014-12-03 08:23:30 -0500

Ramkumar gravatar image

I followed the procedure exactly in the Ubuntu ROS installation page. After installation in ubuntu 12.04 with rosbuild the command 'roscore' returns the error - "ROS master URI is not set".

The following lines are included in ~/.bashrc

ROSLISP_PACKAGE_DIRECTORIES="" ROS_DISTRO="groovy" ROS_ETC_DIR="/opt/ros/groovy/etc/ros" ROS_MASTER_URI="http://localhost:11311" ROS_PACKAGE_PATH="/opt/ros/groovy/share:/opt/ros/groovy/stacks" ROS_ROOT="/opt/ros/groovy/share/ros" source /opt/ros/groovy/setup.bash

Please help me out

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
2

answered 2014-12-03 08:30:48 -0500

dornhege gravatar image

What instructions did you follow? This should not be in your .bashrc. It should only have added:

source /opt/ros/groovy/setup.bash
edit flag offensive delete link more
0

answered 2016-03-24 08:09:22 -0500

yerzhik gravatar image

in my case I just ran the

score ~/.bashrc

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2014-12-03 08:23:30 -0500

Seen: 5,069 times

Last updated: Dec 03 '14