Ask Your Question
1

/rosout not built mac brew

asked 2014-11-13 14:38:04 -0500

Chris7opher gravatar image

updated 2014-11-14 13:05:46 -0500

William gravatar image

Hey,

I installed ROS Indigo through homebrew on Mac Mavericks, when I run 'roscore' I get the following error

ERROR: rosout is not built. Please run 'rosmake rosout'

failed to start core service [/rosout]
The traceback for the exception was written to the log file

running 'rosmake rosout' gives me

[ rosmake ] rosmake starting...
[ rosmake ] Packages requested are: ['rosout']
[ rosmake ] Logging to directory /Users/christopher/.ros/rosmake/rosmake_output-20141113-213542
[ rosmake ] Expanded args ['rosout'] to:
['rosout']
[rosmake-0] Starting >>> catkin [ make ]
[rosmake-0] Finished <<< catkin ROS_NOBUILD in package catkin
 No Makefile in package catkin
[rosmake-0] Starting >>> genmsg [ make ]
[rosmake-4] Starting >>> cpp_common [ make ]
[rosmake-5] Starting >>> cmake_modules [ make ]
[rosmake-4] Finished <<< cpp_common ROS_NOBUILD in package cpp_common
 No Makefile in package cpp_common
[rosmake-5] Finished <<< cmake_modules ROS_NOBUILD in package cmake_modules
 No Makefile in package cmake_modules
[rosmake-4] Starting >>> rostime [ make ]
[rosmake-0] Finished <<< genmsg ROS_NOBUILD in package genmsg
 No Makefile in package genmsg
[rosmake-5] Starting >>> rospack [ make ]
[rosmake-0] Starting >>> genlisp [ make ]
[rosmake-6] Starting >>> gencpp [ make ]
[rosmake-4] Finished <<< rostime ROS_NOBUILD in package rostime
 No Makefile in package rostime
[rosmake-1] Starting >>> roslang [ make ]
[rosmake-3] Starting >>> xmlrpcpp [ make ]
[rosmake-7] Starting >>> genpy [ make ]
[rosmake-4] Starting >>> roscpp_traits [ make ]
[rosmake-5] Finished <<< rospack ROS_NOBUILD in package rospack
 No Makefile in package rospack
[rosmake-0] Finished <<< genlisp ROS_NOBUILD in package genlisp
 No Makefile in package genlisp
[rosmake-5] Starting >>> roslib [ make ]
[rosmake-3] Finished <<< xmlrpcpp ROS_NOBUILD in package xmlrpcpp
 No Makefile in package xmlrpcpp
[rosmake-1] Finished <<< roslang ROS_NOBUILD in package roslang
 No Makefile in package roslang
[rosmake-6] Finished <<< gencpp ROS_NOBUILD in package gencpp
 No Makefile in package gencpp
[rosmake-4] Finished <<< roscpp_traits ROS_NOBUILD in package roscpp_traits
 No Makefile in package roscpp_traits
[rosmake-7] Finished <<< genpy ROS_NOBUILD in package genpy
 No Makefile in package genpy
[rosmake-7] Starting >>> message_generation [ make ]
[rosmake-4] Starting >>> roscpp_serialization [ make ]
[rosmake-5] Finished <<< roslib ROS_NOBUILD in package roslib
 No Makefile in package roslib
[rosmake-5] Starting >>> rosunit [ make ]
[rosmake-7] Finished <<< message_generation ROS_NOBUILD in package message_generation
 No Makefile in package message_generation
[rosmake-4] Finished <<< roscpp_serialization ROS_NOBUILD in package roscpp_serialization
 No Makefile in package roscpp_serialization
[rosmake-7] Starting >>> message_runtime [ make ]
[rosmake-5] Finished <<< rosunit ROS_NOBUILD in package rosunit
 No Makefile in package rosunit
[rosmake-7] Finished <<< message_runtime ROS_NOBUILD in package message_runtime
 No Makefile in package message_runtime
[rosmake-1] Starting >>> std_msgs [ make ]
[rosmake-6] Starting >>> rosbuild [ make ]
[rosmake-1] Finished <<< std_msgs ROS_NOBUILD in package std_msgs
 No Makefile in package std_msgs
[rosmake-6] Finished <<< rosbuild ROS_NOBUILD in package rosbuild                                                [ 2 Active 17/23 Complete ]
 No Makefile in package rosbuild
[rosmake-6] Starting >>> rosconsole [ make ]
[rosmake-1] Starting >>> rosgraph_msgs [ make ]
[rosmake-1] Finished <<< rosgraph_msgs ROS_NOBUILD in package rosgraph_msgs
 No Makefile in package rosgraph_msgs
[rosmake-6] Finished <<< rosconsole ROS_NOBUILD in package rosconsole
 No Makefile in package rosconsole
[rosmake-6] Starting >>> roscpp [ make ]
[rosmake-6] Finished <<< roscpp ROS_NOBUILD in package roscpp
 No Makefile in package roscpp
[rosmake-6] Starting >>> rosout [ make ]
[rosmake-6] Finished <<< rosout ROS_NOBUILD in package rosout
 No Makefile in package rosout
[ rosmake ] Results:
[ rosmake ] Built 23 packages with 0 failures.
[ rosmake ] Summary output to directory
[ rosmake ] /Users/christopher/.ros/rosmake/rosmake_output-20141113-213542

After that, when I run 'roscore' I get the same error again, which says rosout isn't built. With 'rosmaster' everything works fine... What am I doing wrong? Thx for Help

Update (moved by ... (more)

edit retag flag offensive close merge delete

Comments

Please update your question with more information instead of using an answer to do so.

William gravatar imageWilliam ( 2014-11-14 13:06:13 -0500 )edit

Please post the output of export after sourcing your setup.bash file.

William gravatar imageWilliam ( 2014-11-14 13:07:23 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-11-13 15:40:00 -0500

William gravatar image

roscore is built by the catkin_make_isolated command you ran before and no longer by rosmake. That is why it reports being built already when you run rosmake rosout.

It seems more likely that you forgot to source the setup.bash file? The other thing to check is that you actually have rosout in your workspace and that you built it. But if you are following the from source instructions then you should have it.

You said "I installed ROS Indigo through homebrew on Mac Mavericks". Does that mean you are following this tutorial?:

http://wiki.ros.org/indigo/Installati...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-11-13 14:38:04 -0500

Seen: 766 times

Last updated: Nov 14 '14