Ask Your Question
0

installation on OS X Yosemite

asked 2014-11-05 05:29:13 -0600

lteacy gravatar image

Has any brave soul tried this yet? Any luck?

I'm keen to upgrade, but have a working ROS installation running natively on my Mac for first time ever.

Not particularly keen to break it!!

edit retag flag offensive close merge delete

Comments

I tried it, and when I attempt to install the dependencies via rosdep, I get an error regarding the fact that vtk-java is missing.

Tom Moore gravatar imageTom Moore ( 2014-11-05 12:19:50 -0600 )edit

3 Answers

Sort by ยป oldest newest most voted
1

answered 2014-11-17 14:27:49 -0600

l0g1x gravatar image

Just bit the bullet, and it worked for me as a update from 10.9.5 to 10.10. However im using brew python, and not the system python that mac comes with. Im not sure if system python gets updated during this update or not, but i can confirm i have it working on hydro for yosemite. Gazebo, rviz, rqt, and roscore packages all work.

Using brew python 2.7.8

image description

edit flag offensive delete link more

Comments

I upgraded to Yosemite, but I'm unable to install the dependencies as well - collada-dom and pcre . You had the installation right from 10.8 or did you fresh install in 10.9? Since 10.9, stdlib for clang is libc++ instead of libstdc++. Link to question: http://bit.ly/1yHpSCv . Thanks!

chintak gravatar imagechintak ( 2014-12-02 08:40:20 -0600 )edit

im pretty sure i bought my mac during 10.9, but one way or another fresh 10.9 install --> 10.10 upgrade. I installed ROS and solved all dependency issues while still on 10.9, and then when i upgraded, nothing broke and everything worked

l0g1x gravatar imagel0g1x ( 2014-12-02 09:21:49 -0600 )edit

(everything worked, meaning everything that previously worked on 10.9)

l0g1x gravatar imagel0g1x ( 2014-12-02 09:22:33 -0600 )edit
1

answered 2014-11-09 21:47:35 -0600

fergs gravatar image

Not aware of anyone having successfully completed desktop-full (I think you may get away with desktop, based on where errors are being reported). There is an ongoing OSX tracker with a ton of info for OSX+indigo on the rosdistro github: https://github.com/ros/rosdistro/issu...

edit flag offensive delete link more
0

answered 2014-11-23 16:30:57 -0600

lteacy gravatar image

Just upgraded, both on iMac with clean install of home-brew + indigo, and on Macbook with existing indigo install, which still appears to work.

However, having some name resolution issues on laptop, which I wasn't having previously. Works fine when I'm on my institution's VPN, but turn wifi off, and roscore can't launch because it can't ping itself. Setting ROS_MASTER_URI, ROS_IP or ROS_HOSTNAME to explicitly point to localhost / 127.0.0.1 doesn't seem to resolve the issue.

Sounds like Apple have been messing around with name resolution, not aware of a fix yet.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-11-05 05:29:13 -0600

Seen: 790 times

Last updated: Nov 23 '14