Ask Your Question
2

Warning "Map update loop missed its desired rate" keeps on comming

asked 2014-10-21 15:25:52 -0500

Aarif gravatar image

hello, i am setting up Navigation stack as explained in the Navigation Stack Setup Tutorial, My my configuration files are as follows:-

1. base_local_planner_params.yaml

    TrajectoryPlannerROS:
    # for details see: http://www.ros.org/wiki/base_local_planner
    max_vel_x: 0.2
    min_vel_x: 0.05
    max_rotational_vel: 0.5
    min_in_place_rotational_vel: 0.1

    acc_lim_th: 3.2
    acc_lim_x: 2.5
    acc_lim_y: 0

    holonomic_robot: true

    # goal tolerance parameters
    yaw_goal_tolerance: 0.1
    xy_goal_tolerance: 0.2
    latch_xy_goal_tolerance: true

2. costmap_common_params.yaml

  obstacle_range: 2.5
  raytrace_range: 3.0
  footprint: [[0.305, 0.278], [0.04, 0.193], [-0.04, 0.193], [-0.282, 0.178], [-0.282, -0.178], [-0.04, -0.193], [0.04, -0.193], [0.305, -0.278]]
 #footprint: [[0.075, 0.178], [0.04, 0.193], [-0.04, 0.193], [-0.282, 0.178], [-0.282, -0.178], [-0.04, -0.193], [0.04, -0.193], [0.075, -0.178]]
 #robot_radius: ir_of_robot
 inflation_radius: 0.6

 observation_sources: laser_scan_sensor

 laser_scan_sensor: {sensor_frame: openni_depth_frame, data_type: LaserScan, topic: scan, marking: true, clearing: true}

3. global_costmap_params.yaml

  global_costmap:
  global_frame: /map
  robot_base_frame: /base_footprint
  update_frequency: 2.0
  static_map: true

4. local_costmap_params.yaml

  local_costmap:
  global_frame: /map
  robot_base_frame: /base_footprint
  update_frequency: 2.0
  publish_frequency: 2.0
  static_map: false
  rolling_window: true
  width: 6.0
  height: 6.0
  # origin_x: -0.115
  origin_x: 7.5
  origin_y: 7.5
  resolution: 0.05

5. move_base_param.yaml

controller_frequency: 10
controller_patience: 15.0
oscillation_timeout: 10.0
oscillation_distance: 0.5

TrajectoryPlannerROS:
max_vel_x: 0.45
min_vel_x: 0.1
max_rotational_vel: 1.0
min_in_place_rotational_vel: 0.4

acc_lim_th: 1.0
acc_lim_x: 0.5
acc_lim_y: 0.5
path_distance_bias: 50.0
goal_distance_bias: 0.8
holonomic_robot: false

6. move_base.launch

<launch>

  <!-- Run the map server -->
  <node name="map_server" pkg="map_server" type="map_server" args="$(find my_robot_name_2dnav)/map/map.pgm 0.05"/>

  <!--- You can see original move_base.launch -->
  <!--- Run AMCL -->
  <include file="$(find usarsim_inf)/launch/usarsim.launch"/>
  <include file="$(find amcl)/examples/amcl_omni.launch" />



  <node pkg="move_base" type="move_base" respawn="false" name="move_base" output="screen">
    <rosparam file="$(find my_robot_name_2dnav)/launch/costmap_common_params.yaml" command="load" ns="global_costmap" />
    <rosparam file="$(find my_robot_name_2dnav)/launch/costmap_common_params.yaml" command="load" ns="local_costmap" />
    <rosparam file="$(find my_robot_name_2dnav)/launch/local_costmap_params.yaml" command="load" />
    <rosparam file="$(find my_robot_name_2dnav)/launch/global_costmap_params.yaml" command="load" />
    <rosparam file="$(find my_robot_name_2dnav)/launch/move_base_params.yaml" command="load" />
  </node>


  <node pkg="gmapping" type="slam_gmapping" respawn="false" name="slam_gmapping" args="scan:=lms200" >
  </node>

  <node pkg="rviz" type="rviz" respawn="false" name="rviz">
  </node>
</launch>

now where i launch the move_base.launch file everything goes fine but i am getting a warning as:-

  [ WARN] [1413922749.722348193]: Map update loop missed its desired rate of 2.0000Hz... the loop actually took 2.9248 seconds

in my previous question i asked about the reason of this warning but still i am confused and could not remove this warning, please help me out so that i can solve it.

edit retag flag offensive close merge delete

Comments

I have met the same problem,the warning always occured when i tried to change the value of controller_frequency in both larger and smaller conditions. But it seems only a little harm in the running process.I also expect someone who can point out the real problem it is ,with much appreciation.

xqshan gravatar imagexqshan ( 2014-10-21 21:16:36 -0500 )edit

What system are you running on and what sensors and global map size do you get? 3 seconds for an update seems really slow. Does this happen only once?

dornhege gravatar imagedornhege ( 2014-10-22 06:29:31 -0500 )edit

@dornhege i am using ros-fuerte on ubuntu machine. & a p3at in USARSim (on windows machine).

MAP SIZE: 4000, 4000

Subscribed to Topics: laser_scan_sensor

Aarif gravatar imageAarif ( 2014-10-22 13:07:48 -0500 )edit

@dornhege Thanks for you reply.

i have change update frequency from 2.0 to 0.25, now no such kind of warning appears.

but getting a new warning

 Aborting because a valid plan could not be found. Even after executing all recovery behaviors
Aarif gravatar imageAarif ( 2014-10-22 13:21:40 -0500 )edit

@dornhege

click here to view the terminal output

Aarif gravatar imageAarif ( 2014-10-22 13:28:08 -0500 )edit

You just changed the parameters to suppress the warning without solving that it is slow. The other warning could be due to the robot/navigation setup now or still caused by the same problem.

dornhege gravatar imagedornhege ( 2014-10-23 05:17:28 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2014-10-22 03:21:54 -0500

tfoote gravatar image

This means that your map cannot be updated as fast as you've parameterized it. You can choose to use a smaller or lower resolution map or provide more computational power.

edit flag offensive delete link more

Comments

@rfoote then what should be the new value, & where i need to improve. please explain.

Aarif gravatar imageAarif ( 2014-10-22 13:03:09 -0500 )edit

There's a tuning guide

tfoote gravatar imagetfoote ( 2015-01-02 00:13:33 -0500 )edit
0

answered 2016-05-27 03:20:34 -0500

asimay_y gravatar image

updated 2016-05-27 03:24:24 -0500

I think it's a potential bug in navigation stack. please see: https://github.com/ros-planning/navig...

comment r.sleep() will solve the issue.

edit flag offensive delete link more

Comments

where should the r.sleep() be added?

hc gravatar imagehc ( 2018-08-30 10:39:46 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2014-10-21 15:25:52 -0500

Seen: 6,559 times

Last updated: May 27 '16