Ask Your Question
1

Waiting on transform from /base_footprint to /map to become available before running costmap, tf error: [closed]

asked 2014-10-16 15:26:11 -0500

Aarif gravatar image

I want to auto navigate my P3AT.

Using ROS-Fuertr (on PC1: UBUNTU 12.04 LTS) & USARSim (on PC2: windows7 ).

I have my launch file move_base.launch,

<launch>

  <master auto="start"/>
  <!-- Run the map server -->
  <node name="map_server" pkg="map_server" type="map_server" args="$(find my_robot_name_2dnav)/map/map.pgm 0.05"/>

  <!--- You can see original move_base.launch -->
  <!--- Run AMCL -->
  <include file="$(find usarsim_inf)/launch/usarsim.launch"/>
  <include file="$(find amcl)/examples/amcl_omni.launch" />

  <node pkg="move_base" type="move_base" respawn="false" name="move_base" output="screen">
    <rosparam file="$(find my_robot_name_2dnav)/launch/costmap_common_params.yaml" command="load" ns="global_costmap" />
    <rosparam file="$(find my_robot_name_2dnav)/launch/costmap_common_params.yaml" command="load" ns="local_costmap" />
    <rosparam file="$(find my_robot_name_2dnav)/launch/local_costmap_params.yaml" command="load" />
    <rosparam file="$(find my_robot_name_2dnav)/launch/global_costmap_params.yaml" command="load" />
    <rosparam file="$(find my_robot_name_2dnav)/launch/move_base_params.yaml" command="load" />
    </node>

</launch>

but when i try,

$ roslaunch my_robot_name_2dnav move_base.launch

i am getting an warning message,

[ WARN] [1413488778.937642524]: Waiting on transform from /base_footprint to /map to become available before running costmap, tf error:

see here the full terminal output

please help to improve this scenario.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Aarif
close date 2014-12-21 10:54:28.778015

2 Answers

Sort by ยป oldest newest most voted
1

answered 2014-12-21 10:53:25 -0500

Aarif gravatar image

amcl was not getting the laser data from the /scan topic, i fix it and solved the problem.

edit flag offensive delete link more

Comments

how do you solved it?

pexison gravatar image pexison  ( 2015-03-24 10:19:24 -0500 )edit

hi @pexison, my simulator was publishing laser scan on lms200 topic instead of /scan , i remapped the the publishing from lms200 to /scan and that worked form me... if your laser data is being published on /scan topic then you might look on time on both the PCs, the should be synchronize

Aarif gravatar image Aarif  ( 2015-05-02 15:41:48 -0500 )edit

Hi @Aarif, Please tell how did you change the topic from lms200 to /scan?

Waleed_Shahzaib gravatar image Waleed_Shahzaib  ( 2017-05-15 02:58:18 -0500 )edit
2

answered 2014-10-16 19:45:24 -0500

2ROS0 gravatar image

updated 2014-10-16 19:49:03 -0500

Check a couple of things:

  1. Is the time on both the PCs synchronised? It's possible that the time is different across both your machines. In which case, you can set up an NTP server on one of them to synchronise time.
  2. Use the following commands to debug

rosrun tf view_frames

rosrun tf tf_echo /map /base_footprint

(and show us the output of that if you aren't able to figure it out)

Also, there should be a few other related questions on this website since this is a common error and the tf tutorials has help on common pitfalls.

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2014-10-16 15:26:11 -0500

Seen: 11,033 times

Last updated: Dec 21 '14