Ask Your Question
0

openni_launch failed when subscribing to camera/depth/points

asked 2014-10-14 04:20:56 -0500

krykoc gravatar image

updated 2014-10-14 09:14:50 -0500

I am using ROS Groovy Precise 12.04. I have kinect XBox 360. I use to get depth data when i call it in Rviz before, but today even i changed nothing it stops running. Below that is what i got after running rosrun openni_launch openni.launch

process[master]: started with pid [7038]
ROS_MASTER_URI=http://localhost:11311

setting /run_id to 9737daf2-537f-11e4-b663-9439e59a8707
process[rosout-1]: started with pid [7051]
started core service [/rosout]
process[camera/camera_nodelet_manager-2]: started with pid [7063]
[ INFO] [1413276820.002222734]: Initializing nodelet with 4 worker threads.
process[camera/driver-3]: started with pid [7084]
process[camera/debayer-4]: started with pid [7100]
process[camera/rectify_mono-5]: started with pid [7118]
process[camera/rectify_color-6]: started with pid [7132]
process[camera/rectify_ir-7]: started with pid [7146]
process[camera/depth_rectify_depth-8]: started with pid [7160]
process[camera/depth_metric_rect-9]: started with pid [7174]
process[camera/depth_metric-10]: started with pid [7188]
process[camera/depth_points-11]: started with pid [7202]
process[camera/register_depth_rgb-12]: started with pid [7216]
process[camera/points_xyzrgb_sw_registered-13]: started with pid [7230]
process[camera/depth_registered_rectify_depth-14]: started with pid [7244]
process[camera/points_xyzrgb_hw_registered-15]: started with pid [7258]
process[camera/disparity_depth-16]: started with pid [7272]
process[camera/disparity_registered_sw-17]: started with pid [7286]
process[camera/disparity_registered_hw-18]: started with pid [7300]
process[camera_base_link-19]: started with pid [7314]
process[camera_base_link1-20]: started with pid [7326]
process[camera_base_link2-21]: started with pid [7338]
process[camera_base_link3-22]: started with pid [7350]
[ INFO] [1413276821.815545217]: Number devices connected: 1
[ INFO] [1413276821.815637834]: 1. device on bus 003:06 is a SensorV2 (2ae) from PrimeSense (45e) with serial id 'A00365906575051A'
[ INFO] [1413276821.817887418]: Searching for device with index = 1
[ INFO] [1413276821.878690690]: Opened 'SensorV2' on bus 3:6 with serial number 'A00365906575051A'
[ INFO] [1413276822.211703129]: rgb_frame_id = '/camera_rgb_optical_frame' 
[ INFO] [1413276822.211919470]: depth_frame_id = '/camera_depth_optical_frame' 
[ WARN] [1413276822.216726227]: Camera calibration file /home/esetron/.ros/camera_info/rgb_A00365906575051A.yaml not found.
[ WARN] [1413276822.216775997]: Using default parameters for RGB camera calibration.
[ WARN] [1413276822.216831108]: Camera calibration file /home/esetron/.ros/camera_info/depth_A00365906575051A.yaml not found.
[ WARN] [1413276822.216863863]: Using default parameters for IR camera calibration.

Everything seems OK up to this point. I can echo other topics like /camera/depth/image or /camera/ir/image_rect_ir etc. and getting results. However, when i run rostopic echo /camera/depth/points i got something like this;

[camera/camera_nodelet_manager-2] process has died [pid 10360, exit code -11, cmd /opt/ros/groovy/lib/nodelet/nodelet manager __name:=camera_nodelet_manager __log:=/home/esetron/.ros/log/28574b42-5382-11e4-ad34-9439e59a8707/camera-camera_nodelet_manager-2.log].
log file: /home/esetron/.ros/log/28574b42-5382-11e4-ad34-9439e59a8707/camera-camera_nodelet_manager-2*.log

This is same for the calling that frame in Rviz. I even tried Kinect in windows platform and it works great. There is no hardware problem. Any helps?

EDIT 1 : I also tried with " freenect_stack". It gives exactly same error.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2015-05-21 02:20:41 -0500

KDROS gravatar image

It seems, Everything is working correctly.

Open rviz, first select frame from fixed frame to /camera_optical_depth_frame or /camera_link

Now go and add plugins by topics from list

select depth_registered--> pointcloud2 it will add one plugins for pointcloud2--> dropdown topic-->select topic to /depth_registered_points

edit flag offensive delete link more
0

answered 2015-05-21 02:10:49 -0500

tcpu gravatar image

I met the same error.So I want to know how you solve it.Thanks a lot.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2014-10-14 04:20:56 -0500

Seen: 423 times

Last updated: May 21 '15