Ask Your Question
0

Question of controlling multiple ARDrones in tum_simulator

asked 2014-10-02 11:34:31 -0500

Kent gravatar image

Hi guys,

I am currently working on the package of tum_simulator, I would like to spawn multiple ardrones in gazebo and control them seperately.

I managed to fix all the topics, tf and two ardrones were spawned correctly. And the first ardrone can take off, land and be controlled correctly. But when I tried to send a take-off command to the second ardrone, the first one just flew away. (The first ardrone's velocity along z axis just kept rising and the altitude of its navdata finally rise to 3000.)

Do you have any idea about how can I fix that problem? Thanks in advance!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-10-03 04:22:58 -0500

Kent gravatar image

I finally found out what's wrong. It was the problem with the base_links' body name. Each ArDrone seems to have the same base_link body name. But it strange that each Ardrone should belongs to different namespaces. But anyhow, just rewrite the urdf files and make sure every base_link name of each ArDrone is different, which should solve all the problem.

edit flag offensive delete link more

Comments

What version of ROS version were you using? I'm trying to create a similar setup for ROS Kinetic + Gazebo7

tradeA gravatar image tradeA  ( 2018-01-15 19:03:34 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-10-02 11:34:31 -0500

Seen: 122 times

Last updated: Oct 03 '14