Ask Your Question
0

How to Correct wrong Environment setup?

asked 2014-09-30 10:48:45 -0500

GoBaxter gravatar image

updated 2014-09-30 10:54:56 -0500

I was trying to set up my environment variables and typed in the following code:

echo "source /opt/ros/electric/setup.bash" >> ~/.bashrc
source ~/.bashrc

Later i realised i only had groovy, so i changed electric in above to groovy but whenever i try to run ros or baxter, always this message gets displayed that

bash: /opt/ros/electric/setup.bash: No such file or directory

My question is how to get the wrong environment set-up command disabled so that the irritating message is not displayed again and again? Thanks in advance.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-09-30 10:54:41 -0500

dornhege gravatar image

Just remove all lines with electric from your ~/.bashrc with a text editor.

The second message seems to indicate that not roscore is running.

edit flag offensive delete link more

Comments

Where is ~/.bashrc located?

GoBaxter gravatar image GoBaxter  ( 2014-09-30 11:14:23 -0500 )edit
1

in your home directory

dornhege gravatar image dornhege  ( 2014-09-30 11:50:14 -0500 )edit

Thanks. That solved my problem.

GoBaxter gravatar image GoBaxter  ( 2014-09-30 12:41:00 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-09-30 10:48:45 -0500

Seen: 80 times

Last updated: Sep 30 '14