Ask Your Question
0

Problem with cmake + em

asked 2014-09-30 07:32:00 -0500

zeinab gravatar image

Hi, I am trying to use cmake for some source files that I have which I then need to launch as ros nodes. I have src folder for my source code of the ros packages and a build-prefix folder which is my cmake_install_prefix ( in this case /root/openrobots is my cmake_install_prefix ). When I run ccmake .. in the build folder which is inside my src/ros_package folder, this is what I get:

 CMake Error at
 /root/openrobots/share/catkin/cmake/safe_execute_process.cmake:11 (message):
   execute_process(/root/src/ranger_ros/build/catkin_generated/env_cached.sh
   "/usr/bin/empy" "--raw-errors" "-F"
   "/root/src/ranger_ros/build/catkin_generated/pkg.develspace.context.pc.py"
   "-o" "/root/src/ranger_ros/build/devel/lib/pkgconfig/ranger_ros.pc"
   "/root/openrobots/share/catkin/cmake/em/pkg.pc.em") returned error code 2
 Call Stack (most recent call first):
   /root/openrobots/share/catkin/cmake/em_expand.cmake:23
 (safe_execute_process)
   /root/openrobots/share/catkin/cmake/catkin_package.cmake:355 (em_expand)
   /root/openrobots/share/catkin/cmake/catkin_package.cmake:98
 (_catkin_package)
   CMakeLists.txt:15 (catkin_package)

Any idea on how I can solve this issue? Thanks a lot

edit retag flag offensive close merge delete

Comments

Try running the command printed in execute_process() manually. May be that gives you more information than just error code 2.

Dirk Thomas gravatar image Dirk Thomas  ( 2014-09-30 11:31:05 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-09-30 17:06:41 -0500

zeinab gravatar image

Apparently empy was missing and after installing itthis issue was resolved. However I would still get some errors because of boost system libraries. I then had to install two different version of libboost-system1.40 and libboost-system1.56 and I was able to make!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-09-30 07:32:00 -0500

Seen: 161 times

Last updated: Sep 30 '14