Ask Your Question
5

CMake Error: CMAKE_MODULE_PATH does not contain Findcatkin.cmake

asked 2013-07-24 11:53:01 -0500

atp gravatar image

updated 2013-11-14 10:33:21 -0500

tfoote gravatar image

I'm trying to install rviz from source. It seems a lot of packages are missing from my installation of ROS from source. So, I worked my way through the github repository, cloned the corresponding folders, copied them into /opt/ros/..., and ran cmake to build the packages from source. This worked fine until the package "genpy" where cmake gives the following error:

CMake Error at CMakeLists.txt:4 (find_package):
  By not providing "Findcatkin.cmake" in CMAKE_MODULE_PATH this project has
  asked CMake to find a package configuration file provided by "catkin", but
  CMake did not find one.

  Could not find a package configuration file provided by "catkin" with any
  of the following names:

    catkinConfig.cmake
    catkin-config.cmake

  Add the installation prefix of "catkin" to CMAKE_PREFIX_PATH or set
  "catkin_DIR" to a directory containing one of the above files.  If "catkin"
  provides a separate development package or SDK, be sure it has been
  installed.
edit retag flag offensive close merge delete

Comments

Were you able to fix this problem? I get the same error with suitesparse.

saba426 gravatar imagesaba426 ( 2015-09-10 10:09:08 -0500 )edit

I'm also having this issue, has anyone found a working solution? (nothing listed below works for me)

M@t gravatar imageM@t ( 2017-09-25 15:43:03 -0500 )edit

@M@t this is a very old solved question. It doesn't make sense to try to revive this. Please ask your question as a new question with full details on how to reproduce it. http://wiki.ros.org/Support

tfoote gravatar imagetfoote ( 2017-09-25 16:05:18 -0500 )edit

There seems to already be a few questions with this same issue that exist, such as this question, so I'm reluctant to open a duplicate question. Unfortunately, the answer given doesn't work for me.

M@t gravatar imageM@t ( 2017-09-25 16:23:15 -0500 )edit

I'll keep searching for an answer, and if I find one I'll reopen the question linked above and give a full answer. If not, I'll take your suggestion and open a fresh question.

M@t gravatar imageM@t ( 2017-09-25 16:27:43 -0500 )edit

The problem you're running into is very generic. The catkinConfig.cmake is not on your CMAKE_PREFIX_PATH. The question is why it's not on your path. The only way to know that is to have enough information to reproduce the problem you are having exactly, since it's likely a procedural error.

tfoote gravatar imagetfoote ( 2017-09-25 16:30:22 -0500 )edit

I see, I'll start collecting everything I need to make a proper question. Thanks for the help, I appreciate it.

M@t gravatar imageM@t ( 2017-09-25 16:53:26 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
3

answered 2013-07-24 14:40:07 -0500

fergs gravatar image

map_msgs is a ROS package, so you need to install map_msgs from source, it is not installed by rosdep: find the github repository that it is in here: http://ros.org/wiki/map_msgs

edit flag offensive delete link more

Comments

I think this just leads to a cycle of problems (see above).

atp gravatar imageatp ( 2013-07-24 16:20:56 -0500 )edit

Did you build it ? I think you might need to compile those files...

Lucile gravatar imageLucile ( 2013-07-24 23:10:34 -0500 )edit

see above. I adjusted the problem description to the most recent problem - I hope that's fine.

atp gravatar imageatp ( 2013-07-25 04:13:29 -0500 )edit

Did you try rosmake tools as well ? Maybe this package has not been catkinised yet...

Lucile gravatar imageLucile ( 2013-07-25 21:59:46 -0500 )edit
1

answered 2016-03-24 21:13:26 -0500

Craig gravatar image

i get the same problem for catkin_simple By not providing "Findcatkin_simple.cmake" in CMAKE_MODULE_PATH this project has asked CMake to find a package configuration file provided by "catkin_simple", but CMake did not find one.

Could not find a package configuration file provided by "catkin_simple" with any of the following names:

catkin_simpleConfig.cmake
catkin_simple-config.cmake

Add the installation prefix of "catkin_simple" to CMAKE_PREFIX_PATH or set "catkin_simple_DIR" to a directory containing one of the above files. If "catkin_simple" provides a separate development package or SDK, be sure it has been installed.

edit flag offensive delete link more

Comments

have you solved the problem? I got the same problem.

jjsmonkey gravatar imagejjsmonkey ( 2016-07-01 13:21:18 -0500 )edit
0

answered 2016-08-30 09:38:04 -0500

ToXeR gravatar image

For a general solution for the "catkin_simple" problem, I just cloned catkin_simple into my workspace

https://github.com/catkin/catkin_simple

I don't know if this is the correct way, but it worked

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-07-24 11:53:01 -0500

Seen: 16,634 times

Last updated: Aug 30 '16