unable to open catkin workspace with QT creator [closed]

asked 2016-12-25 00:04:22 -0500

The Gimmickk gravatar image

updated 2017-09-25 16:34:05 -0500

M@t gravatar image

I am using Ubuntu 14.04, ROS indigo, Qt Creator 3.0.1

when I try to open any catkin package in the workspace, following error pops up every time.

CMake Error at CMakeLists.txt:7 (find_package):
  By not providing "Findcatkin.cmake" in CMAKE_MODULE_PATH this project has
  asked CMake to find a package configuration file provided by "catkin", but
  CMake did not find one.

  Could not find a package configuration file provided by "catkin" with any
  of the following names:


  Add the installation prefix of "catkin" to CMAKE_PREFIX_PATH or set
  "catkin_DIR" to a directory containing one of the above files.  If "catkin"
  provides a separate development package or SDK, be sure it has been

  -- Configuring incomplete, errors occurred!
  See also "/home/kk/catkin_ws_navigation/build/nav2d_exploration/CMakeFiles/CMakeOutput.log".

I am trying to open Navigation_2d package present [here] ( https://github.com/skasperski/navigat... ) .All the packages are successfully built in the build directory. Can anyone please help me out I am totally stuck

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by The Gimmickk
close date 2016-12-26 07:44:52.324016


I have successfully solved the problem. As once you run the command

sudo qtcreator CMakelists.txt

Qt creator automatically makes a cache file in the build folder you have chosen. So I had to rebuild the catkin_package and then the problem was solved

The Gimmickk gravatar image The Gimmickk  ( 2016-12-26 07:50:25 -0500 )edit

Can you tell us why you'd want to run qtcreator with super user access? That in itself is not a good idea.

gvdhoorn gravatar image gvdhoorn  ( 2016-12-26 09:09:48 -0500 )edit