Ask Your Question
0

OS X installation error

asked 2014-09-29 08:24:34 -0600

borisbr gravatar image

Hello when i try to run " ./src/catkin/bin/catkin_make_isolated --install -DCMAKE_BUILD_TYPE=Release" the install failed with the following error "library not found for -ltinyxml". i already install tinyxml using brew and tried to reinstall but with same result. Thank

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
0

answered 2014-11-26 13:05:18 -0600

tropic gravatar image

I received this error when it came to image_transport from image_common. What you can do, if it is image_transport that throws the error, is to edit the CMakeList.txt in ros_catkin_ws/src/image_common/image_transport and remove the line with tinyxml

add_dependencies(${PROJECT_NAME} sensor_msgs_gencpp)
target_link_libraries(${PROJECT_NAME}
  ${Boost_LIBRARIES}
  ${catkin_LIBRARIES}
#  tinyxml
)

See these two links from the issue tracker

edit flag offensive delete link more
0

answered 2014-10-01 02:05:51 -0600

borisbr gravatar image

Thanks it help for solve this problem, but now i have new one.

"Linking CXX executable /Users/borisbraginsky/ros_catkin_ws/devel_isolated/pluginlib/lib/pluginlib/plugin_tool clang: error: -E or -x required when input is from standard input make[2]: * [/Users/borisbraginsky/ros_catkin_ws/devel_isolated/pluginlib/lib/pluginlib/plugin_tool] Error 1 make[1]: [CMakeFiles/plugin_tool.dir/all] Error 2 make: ** [all] Error 2"

edit flag offensive delete link more

Comments

please ask a new question, don't follow up in an answer.

tfoote gravatar imagetfoote ( 2014-12-16 02:24:05 -0600 )edit
0

answered 2014-09-30 22:35:48 -0600

jseal gravatar image

I had the same problem and I can't quite remember exactly how I fixed it, but here is what I remember.

After the build fails it gives you the command it failed on and the error you stated. How I got to compile was to cd to the directory that it failed in. I ran grep -r ltinyxml *, the results yield a link.txt file and I replace the -ltinyxml in that file with /usr/local/Cellar/tinyxml/2.6.2/lib/libtinyxml.dylib and rebuilt

you might want to verify the version and path for tinyxlml are the same for you. It's a bit of a hack but it works.

Another helpful note is that catkin_make_isolated has a from-pkg build option that allows you to pick up where you left off.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-09-29 08:24:34 -0600

Seen: 234 times

Last updated: Nov 26 '14