rosserial_python Failed Packet Flags + Lost Sync With Device, Restarting

asked 2014-09-22 03:06:17 -0600

Nightstalker gravatar image

updated 2014-09-23 12:56:09 -0600

I am using ROS Groovy on my RasPi and the Arduino Leonardo and the Arduino Mega 2560.
I was trying out the sample Push Button code given on on the RasPi using my Leonardo and the Mega. The code uploaded just fine on both Mega and Leonardo. However, when I run rosrun rosserial_python /dev/ttyACM0, I get the following message:

[INFO] [WallTime: 1411372730.262631] ROS Serial Python Node
[INFO] [WallTime: 1411372730.267892] Connecting to /dev/ttyACM0 at 57600 baud
[INFO] [WallTime: 1411372732.420500] Failed Packet Flags

I checked out the solution given here and here but none of that worked. It seems to be a memory problem, but I can't figure out exactly where to begin solving this problem.

edit retag flag offensive close merge delete


@ahendrix, please help me out here.

Nightstalker gravatar image Nightstalker  ( 2014-09-23 02:48:31 -0600 )edit

I got nothing on this one. sorry.

ahendrix gravatar image ahendrix  ( 2014-09-23 02:59:44 -0600 )edit

You could try opening a ticket on the rosserial repo , but since groovy is (approaching) end-of-life, you're unlikely to find much help.

paulbovbel gravatar image paulbovbel  ( 2014-09-23 12:58:39 -0600 )edit

You can see that the latest groovy branch is 200 commits behind indigo, meaning there's a lot of work/potential fixes that haven't been backported.

paulbovbel gravatar image paulbovbel  ( 2014-09-23 12:58:59 -0600 )edit

Yeah, I agree with that @paulbovbel. But people have gotten the "Hello World" working on Groovy. Even that isn't working for me.

Nightstalker gravatar image Nightstalker  ( 2014-09-23 13:08:12 -0600 )edit