rosserial_python: Serial port read failure

asked 2016-04-27 08:03:27 -0500

mitch gravatar image

I have followed the tutorials for setting up the Arduino IDE and loaded the Hello World sketch to my Arduino.

When I run: rosrun rosserial_python serial_node.py /dev/ttyUSB0, I get:
[WARN] [WallTime: 1461761129.635609] Serial Port read failure:
[INFO] [WallTime: 1461761129.636331] Packet Failed : Failed to read msg data
[INFO] [WallTime: 1461761129.636872] msg len is 8
[WARN] [WallTime: 1461761129.653651] Serial Port read returned short (expected 74 bytes, received 58 instead).

This had previously worked. Since then, I have installed catkin and did the Simple Publisher and Subscriber tutorial so that probably affected something with the ROS Arduino setup.

I am using Ubuntu 14.04 with ROS Indigo and arduino-1.6.8 and would appreciate any suggestions for tracking down the problem.

edit retag flag offensive close merge delete

Comments

Same issue, were you able to fix this?

Sidd gravatar imageSidd ( 2016-08-30 18:21:45 -0500 )edit

Unfortunately no.

mitch gravatar imagemitch ( 2016-08-30 19:27:31 -0500 )edit

I was experimenting with different baud rates and it seemed like having a baud rate of >= 115200 seems to make it work.

Sidd gravatar imageSidd ( 2016-08-30 19:55:56 -0500 )edit

Thanks. I don't have this set up any more, but will try that when I do.

mitch gravatar imagemitch ( 2016-08-31 06:51:48 -0500 )edit