Ask Your Question
1

OpenGL error when run rviz

asked 2014-09-02 00:36:50 -0500

Frank gravatar image

updated 2014-09-02 01:11:32 -0500

Hi all,

After I successfully install ros on my PC. I try to run rviz, but come cross an error as follows

rosrun rviz rviz
[ INFO] [1409663641.718819061]: rviz version 1.11.3
[ INFO] [1409663641.718874433]: compiled against OGRE version 1.8.1 (Byatis)
Xlib:  extension "NV-GLX" missing on display ":0".
Xlib:  extension "NV-GLX" missing on display ":0".
[ INFO] [1409663641.808060686]: Stereo is NOT SUPPORTED
[ INFO] [1409663641.808351168]: OpenGl version: 1.4 (GLSL 0).
terminate called after throwing an instance of 'std::runtime_error'
  what():  Your graphics driver does not support OpenGL 2.1. Please enable software rendering before running RViz (e.g. type 'export LIBGL_ALWAYS_SOFTWARE=1').

Is there any solution about this? Thank you.

Best Regards!

Frank

edit retag flag offensive close merge delete

Comments

Have you solve this problem?I met the same problem,Can you share how to solve it?

yincanben gravatar image yincanben  ( 2014-12-25 05:35:46 -0500 )edit

Hi, did anyone solved this ?, I just have this error after I installed various graphics and CUDA drivers to get some 3D cameras working...

Cyril_J gravatar image Cyril_J  ( 2015-10-16 08:57:55 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-09-02 01:16:03 -0500

updated 2014-09-02 01:17:58 -0500

According to the exception message, it looks like your graphics driver does not support OpenGL 2.1.

If your graphics card does not support hardware acceleration try the following (rviz might run excruciatingly slow, but at least it should run) :

$> export LIBGL_ALWAYS_SOFTWARE=1
$> rosrun rviz rviz

If you are certain that your graphics card does support hardware acceleration, make sure that you have installed the adequate driver (proprietary driver?)

edit flag offensive delete link more

Comments

1

Hi, I'm running into the exact same problem as the original post (my OpenGL version is also 1.4) but exporting LIBGL_ALWAYS_SOFTWARE=1 does not fix the problem. I'll run the two lines you mention and the exact same error will occur. Is there anything else to test for/try as a fix?

Eric Schneider gravatar image Eric Schneider  ( 2015-01-22 14:57:43 -0500 )edit

That env variable appears to be a mesa specific thing, people using different drivers may not get the desired affect: http://www.mesa3d.org/envvars.html

William gravatar image William  ( 2015-01-22 15:36:12 -0500 )edit

Hm. In that case I don't know how to fix the problem. I'll try to figure out which drivers I'm using. Thanks.

Eric Schneider gravatar image Eric Schneider  ( 2015-01-22 17:58:00 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2014-09-02 00:36:50 -0500

Seen: 4,231 times

Last updated: Sep 02 '14